Author Topic: No games/roms show up in the UI  (Read 1242 times)

0 Members and 1 Guest are viewing this topic.

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
No games/roms show up in the UI
« on: September 02, 2021, 10:55 PM »
Hi, I have an issue, I don't know if it's me not understanding how to add roms properly.

The firmware launches quickly, but show no games in the list. I've tried:

  • adding the roms to the root of the SD card
  • adding the roms in a subfolder of the root (root/roms/the_rom.smc)
  • adding the roms in the SD2SNES subfolder (root/sd2snes/the_rom.smc)

What am I doing wrong? I attached a screenshot of what I see.

Offline Relikk

  • Sr. Member
  • ****
  • Posts: 424
  • Karma: +36/-8
    • View Profile
Re: No games/roms show up in the UI
« Reply #1 on: September 02, 2021, 11:14 PM »
A bit odd, indeed. Your first two options should be fine, although a dedicated folder on the root for ROMs is recommended as per your second option. Don't put any game ROMs inside the SD2SNES folder. Only the firmware, the BIOS files and whatever files and folders the SD2SNES itself creates should be in there.

Make sure the pins in your cartridge slot are clean. Try another SNES if you can, and try other power supplies if you can. The SD2SNES/FXPak draws more power than what some ageing OEM PSU's can supply.

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #2 on: September 02, 2021, 11:29 PM »
Unfortunately I have no other SNES to test it on. But since it boots the firmware and shows the empty list, it shouldn’t be a power issue, right?

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #3 on: September 02, 2021, 11:32 PM »
Is all types of characters supported in the file names of the roms?

Online nuu

  • Hero Member
  • *****
  • Posts: 2310
  • Karma: +99/-2
    • View Profile
Re: No games/roms show up in the UI
« Reply #4 on: September 03, 2021, 09:38 AM »
Almost certainly not, try to limit filenames to ASCII. The firmware seems to have some Japanese font but it might not work with just any encoding.

Quote
since it boots the firmware and shows the empty list, it shouldn’t be a power issue, right?
It could always be a power issue. It's a very unpredictable problem.

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #5 on: September 03, 2021, 10:40 PM »
I got it to work now, bu cleaning the cartridge slot. Turns out the us just hanged on boot and that’s why no games showed up. Unfortunately I still have to clean/blow the slot between each boot/power cycle, so I’m not really sure if that’s the real issue or something else is going on.

Offline Relikk

  • Sr. Member
  • ****
  • Posts: 424
  • Karma: +36/-8
    • View Profile
Re: No games/roms show up in the UI
« Reply #6 on: September 04, 2021, 01:38 AM »
Some of the cart slot pins might not be making a consistent connection with the cart. If you can see any that might look like they're bent inwards a little more than they should, you can try bending them back out gently and carefully.

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #7 on: September 04, 2021, 06:05 PM »
None of my physical cartridges use the two narrow slots of the console, so those slots may have some oxidation, since they have never been in contact with anything. All physical games runs fine, so I guess the issue lies within those slots.

I’ve tried to clean them with isopropanol, but in the end it seems like the only thing that helps is blowing hard into these side slots, before turning on the system. None of the pins look bent in any way.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 1027
  • Karma: +56/-0
    • View Profile
    • gamehacking.org
Re: No games/roms show up in the UI
« Reply #8 on: September 04, 2021, 08:16 PM »
which super famicom model you have ?

on sd2snes menu press x
if  PPU2 is revision 1 that is problem
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
RetroUSB AVS | Super NT | Mega SG | Super Retro Advance |  16bitPocket GBC | PCE+SSD3

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #9 on: September 04, 2021, 08:47 PM »
It says:
CPU/PPU1/PPU2: 2/1/3

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 1027
  • Karma: +56/-0
    • View Profile
    • gamehacking.org
Re: No games/roms show up in the UI
« Reply #10 on: September 04, 2021, 09:14 PM »
which firmware version you using?
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
RetroUSB AVS | Super NT | Mega SG | Super Retro Advance |  16bitPocket GBC | PCE+SSD3

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #11 on: September 04, 2021, 10:59 PM »
1.10.3

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #12 on: September 05, 2021, 08:10 PM »
I will try to use some fine grained sand paper on the slot pins and see if that makes the contact better permanently. I’m thinking that blowing in the slot adds moisture, which improves the contact temporarily.

Online nuu

  • Hero Member
  • *****
  • Posts: 2310
  • Karma: +99/-2
    • View Profile
Re: No games/roms show up in the UI
« Reply #13 on: September 06, 2021, 01:44 PM »
Yes that's the theory but the moisture also hurries up the pin oxidation which makes it worse in the long run. Just reinserting the cartridge also improves the chances for better contact so it may seem to help more than it does.
You could also try isopropyl alcohol with a toothbrush and scrub the slot very thoroughly.

Offline flyrider

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: No games/roms show up in the UI
« Reply #14 on: September 06, 2021, 03:57 PM »
Sandpapering didn’t help unfortunately. But I can now confirm that leaving the FXPak menu on for about 10 minutes, then the time display in the right corner starts flickering like crazy and after that it’s impossible to load any game.

Now I tried just breathing into the slot instead of blowing, and that helps as well. So my theory about the moisture increasing contact is probably correct.

Thanks, I’ll try the toothbrush approach.