Author Topic: Everdrive GBA X5 Mini system won't boot after playing NES, GG or SMS games  (Read 493 times)

0 Members and 1 Guest are viewing this topic.

Offline mario64

  • Full Member
  • ***
  • Posts: 179
  • Karma: +2/-0
    • View Profile
I'm using a GBA X5 Mini with my GBA SP running OS 1.15. I have all the recommended emulators loaded. Regular GBA games as well as GB and GBC games work fine. However, I've noticed that if play a NES, GG or SMS game then power off my GBA, the console won't boot up. When I press the power switch nothing at all happens. The only way to fix this is to unplug the Everdrive then plug it back in. Then my GBA will boot up. Any idea what's going on here? Are the emulators for NES, GG and SMS games not fully compatible with the X5 Mini? Thanks

Online nuu

  • Hero Member
  • *****
  • Posts: 2314
  • Karma: +99/-2
    • View Profile
How long do you wait before powering on again?

Offline mario64

  • Full Member
  • ***
  • Posts: 179
  • Karma: +2/-0
    • View Profile
How long do you wait before powering on again?
Couple of seconds I guess

Online nuu

  • Hero Member
  • *****
  • Posts: 2314
  • Karma: +99/-2
    • View Profile
Try waiting at least 20 seconds.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 1027
  • Karma: +56/-0
    • View Profile
    • gamehacking.org
I have x5 mini no problem on  Super Retro Advance re-power on snes again into OS menu after playing Goomba Color and PocketNES Dwedit builds
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
RetroUSB AVS | Super NT | Mega SG | Super Retro Advance |  16bitPocket GBC | PCE+SSD3

Offline mario64

  • Full Member
  • ***
  • Posts: 179
  • Karma: +2/-0
    • View Profile
Try waiting at least 20 seconds.
Why would that be necessary?

Offline JCR1

  • Newbie
  • *
  • Posts: 35
  • Karma: +2/-0
    • View Profile
Try with another gba, mine boots fine even in low batt red led, ips screen  gba sp, i love these emulators.

Online nuu

  • Hero Member
  • *****
  • Posts: 2314
  • Karma: +99/-2
    • View Profile
Try waiting at least 20 seconds.
Why would that be necessary?
Trouble shooting the problem.