Author Topic: [SOLVED] FXPAK Pro not booting/visual banding  (Read 236 times)

0 Members and 2 Guests are viewing this topic.

Offline Freechips

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
[SOLVED] FXPAK Pro not booting/visual banding
« on: July 19, 2021, 09:03 PM »
Turning on the console (SFC) shows this:

It seems like the console is a bit broken, but I'm wondering if it's fixable, or if I just need to roll the dice getting another one off ebay.
Standard game carts do seem to work fine apart from occasionally showing some mild visual artifacts (the horizontal banding), but it's much worse when using the FXPAK Pro.
I opened the snes up, but couldn't see anything obviously wrong to the naked eye. The log says the CPU failed, so I guess this somehow causes the video glitch?

Code: [Select]
===log opened===
flash check:   1d62b458-b82d6850-82-11-0 
SD test... please insert card
crc1 = 8a0b9767 crc2 = 8a0b9767   PASSED

RTC Test
setting clock to 2019-02-23 00:00:00
2019-02-23 00:00:00
waiting 2 seconds
new time: 2019-02-23 00:00:02

FPGA test
configuring fpga...
basic communication test...PASSED

RAM connection test

Testing RAM0.1 (U501)...

Testing RAM0.2 (U502)...

Testing RAM1 (U511)...

SD DMA test
clearing RAM - loading test file - verifying -PASSED

Loading SNES test ROM

sysclk test
measuring SNES clock...
21477717 Hz
21477712 Hz diff = 5  max = 5
21477712 Hz diff = 0  max = 5
21477712 Hz diff = 0  max = 5
   CPUCLK: 2913939
  READCLK: 2610037
 WRITECLK: 77660
  PARDCLK: 72773
  PAWRCLK: 75960
  REFRCLK: 67218
   CICCLK: 3077391

SNES test status: IRQ: 00   PA: 00   MEM: 00/00
** SNES CPU ERROR. CHECK RAM TEST, CLK TEST, FBA101, FBA102, RA103-109, RA121-122, U101-103, FPGA


flash check:   1d62b458-b82d6850-82-11-0 
Test      Result
SD        Passed
USB       not implemented
RTC       Passed
CIC       no run
FPGA      Passed
RAM       Passed
SD DMA    Passed
CLK       Passed
DAC       not implemented
SNES IRQ  no run
SNES RAM  no run

Any help appreciated :)
« Last Edit: August 03, 2021, 05:48 PM by Freechips »

Offline Freechips

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: FXPAK Pro not booting/visual banding
« Reply #1 on: August 03, 2021, 05:47 PM »
Managed to get it working with a different power supply. The new power supply [10V 0.85A] as opposed to the previous, standard UK ones I'd tried [9V 1.3A].
Funnily enough, the power supply was my first suspect when I started seeing this banding, obviously, trying another one with the same voltage specs gave the same result. Since the snes was still functional, I figured it must be something else, but no.