EverDrive Forum

General => FXPAK (SD2SNES) => Topic started by: VietKongCountry on July 07, 2018, 04:19 PM

Title: Issues with the game Imperium (freezes within seconds of starting it).
Post by: VietKongCountry on July 07, 2018, 04:19 PM
I posted this on the SNES reddit but it seems to be something nobody else is having problems with. I've tried multiple ROMs of the game, both Japanese and American versions and different updates of the SD2SNES firmware. Regardless of the combination, the game will freeze somewhere between 2-10 seconds of starting. Does anybody know what might cause this? I'm leaning towards some kind of issue with the DSP files, but other games that definitely use them run fine. Any help greatly appreciated.
Title: Re: Issues with the game Imperium (freezes within seconds of starting it).
Post by: lee4 on July 07, 2018, 06:33 PM
question for you

you have SNES PAL ?

you have SuperCIC ?

you are using official v1.80 ?

this freezing is part of region locking to stop play NTSC games on PAL system and vice versa
Title: Re: Issues with the game Imperium (freezes within seconds of starting it).
Post by: ErivandoXP on July 08, 2018, 01:10 AM
Imperium works fine here (1.8.0 Snes NTSC IGH On)
Title: Re: Issues with the game Imperium (freezes within seconds of starting it).
Post by: VietKongCountry on July 08, 2018, 03:41 PM
question for you

you have SNES PAL ?

you have SuperCIC ?

you are using official v1.80 ?

this freezing is part of region locking to stop play NTSC games on PAL system and vice versa

Sorry, should have specified. No PAL anything involved. Tried this on a North American 2 chip SNES and a 1 chip Super Famicom with the exact same result.

Official firmware and have tried the pre-Super FX version and the current release with the same result on both consoles. I have the region set to "Auto" I believe, but I doubt that's the issue since I'm playing on hardware the game was designed for.
Title: Re: Issues with the game Imperium (freezes within seconds of starting it).
Post by: lee4 on July 08, 2018, 07:14 PM
both games (CRC32=2624F8BD & CRC32=1E54F2C6)
run fine with v1.80 on usa snes jr
Title: Re: Issues with the game Imperium (freezes within seconds of starting it).
Post by: VietKongCountry on July 10, 2018, 12:02 AM
This is just weird, then. Tried various ROMs on both consoles with various official firmware versions and different settings. Set the region/speed to auto, to 60hz, turned SuperCIC on and off, etc. People who have the exact same ROM set as me say it works, too. Any idea what else could cause this? Do any SD cards somehow have weirdly specific compatibility issues or could I have bad DSP files maybe? Playing the game a tiny bit it doesn't look to use mode 7 as I'd suspected, though, so I don't know anymore. Contemplating buying a copy of the game to see if that works, since it's a cheap one.