Author Topic: New Everdrive GB X7 Issues  (Read 767 times)

0 Members and 1 Guest are viewing this topic.

Offline MeatyMuffin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
New Everdrive GB X7 Issues
« on: March 12, 2021, 08:03 AM »
I’ve been experiencing issues with an Everdrive GB X7 that I received earlier today. Here’s a rundown of the problems so far:

At first I started playing it plugged into my GameBoy Player on my GCN. Played a few minutes of the opening of Pokémon Crystal without issue until I walked away for a moment and came back to a black screen within the GBP border. I reset the GCN and ran a diagnostic that showed everything to be fine but upon reading “Press any button to continue.” Boom another black screen.

Decided to switch over to different hardware just in case. GBA SP for the next test. No resets this time and I set up the RTC in menu. The next issue is where the cart kept trying to open the save state screen at random. After resetting the system I’m greeted with a message that the battery was dead in my brand new cart and that RTC had reset itself. A couple more freezes and I’m back to square one. The same case followed using a GBA and a GBC.

So my question at this point is have any of you experienced similar issues or do I have a faulty cartridge?

Offline MeatyMuffin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: New Everdrive GB X7 Issues
« Reply #1 on: March 13, 2021, 12:47 PM »
Continued testing has shown that it isn’t an issue with the SD card and the problems have persisted across five separate cards of varying sizes and brands. Also it isn’t an issue with dirty contacts as they’re still happening even after a thorough cleaning of the contacts and pins on a few mediums. I’ve also started to notice additional issues such as the Diagnostics screen throwing an RTC error with letters in place of numbers, page skipping in the menus across every folder, and occasional full screens of garbled messages accompanied by hard freezes where the access light on the cartridge just seems to completely give up.

I’m 100% convinced it’s a defective unit at this point because none of the other carts I’ve owned made by Krikzz have given me a single issue in the past. I trust the build quality of these things but there’s a first time for everything.

Offline nuu

  • Hero Member
  • *****
  • Posts: 2087
  • Karma: +88/-2
    • View Profile
Re: New Everdrive GB X7 Issues
« Reply #2 on: March 13, 2021, 01:13 PM »
Sounds like something is wrong with it.
There is a customer service form on the main page you can use to contact Krikzz.