Author Topic: Mega ED Pro: Added missing GnG and SOR Roms , they boot to black screen  (Read 860 times)

0 Members and 1 Guest are viewing this topic.

Offline Josh128

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
So I have a good working MEDPro, with a huge collection of ROMs, they all work.  I noticed somehow I didn't have Streets of Rage and Ghouls N Ghosts, so I pulled them from known working .smd roms on my PC.  Put them in the folders, they just boot to black screen, no splash logo even.  Downloaded new roms, same issue.  Tried renaming them to .md from .smd.  Same issue.

Is there something about adding roms individually that  causes an issue like this?  how do I fix it?

Offline nuu

  • Hero Member
  • *****
  • Posts: 2226
  • Karma: +98/-2
    • View Profile
No I added all my roms individually. Maybe you got bad roms. Did you try no-intro roms?

Offline birdybro

  • Newbie
  • *
  • Posts: 10
  • Karma: +1/-0
    • View Profile
So I have a good working MEDPro, with a huge collection of ROMs, they all work.  I noticed somehow I didn't have Streets of Rage and Ghouls N Ghosts, so I pulled them from known working .smd roms on my PC.  Put them in the folders, they just boot to black screen, no splash logo even.  Downloaded new roms, same issue.  Tried renaming them to .md from .smd.  Same issue.

Is there something about adding roms individually that  causes an issue like this?  how do I fix it?

SMD roms are an interleaved format, they should basically be considered a legacy format that you shouldn't use anymore. They have to be converted.

https://segaretro.org/SMD

Convert them with this (or something similar):

https://www.romhacking.net/utilities/383/

Or just download ones that aren't in the legacy format from decades ago :P