General > Super EverDrive

Simcity opening is all glitchy

(1/2) > >>

Hey there I was just wondering if SimCity (US) was known to have a glitchy opening? On my super everdrive X5 I've tried different US roms of the game but I get this weird looking intro every time I start it, but if I press a button the menu display perfectly fine and the whole game play with no problem so it's only the opening that's just broken. Not a big deal but I loved watching that chill opening with the music ahah.

Strangely the last time I tried it to get this picture I saw some ALTTP title screen sprites scrolling through the screen (I could read A LINK TO with the same font), and that was the last game I ran just before trying simcity.

Sounds like a bug with the SED. It might need to clean the memory before loading games to avoid this.

Strangely tho this is the only game that this happen to, also happen even if it's the first game I boot up after turning on my SNES.

But now while looking through the options I saw quick reset was ON and turned it OFF, booting up simcity still had all the weird glitches but when I reset the console instead of going back to the menu it reboot the game only and this time the graphics are perfectly fine! As if it really needs to be the first thing to start, so no OS menu (Yeah now that I think about it when I choose simcity as the first game to boot the sprites seems to be the font used in the SED menu)


So it was an initialization problem like I thought. The Everdrive is leaving some part of the SNES in a state that Sim City doesn't expect from a cold boot and doesn't initialize it correctly. There are more games like this but the symptoms may be different for every game, it can be sound or graphical. Krikzz might already have spotted and fixed many of them.

So is this something that could be fixed with an OS update or maybe with a rom patch? Is this something I should notify Krikzz about?


[0] Message Index

[#] Next page

Go to full version