EverDrive Forum

General => Turbo EverDrive => Topic started by: Kez on November 24, 2017, 01:20 AM

Title: TBED - Games don't always start
Post by: Kez on November 24, 2017, 01:20 AM
Hi, I have had a Turbo Everdrive v2.5 for a few weeks now. I have a strange problem in that ROMs simply will not load reliably. When a game fails to load, the access LED on the card will flicker on and off once and then I just get a black screen. I have found the easiest way to load a game I want to play is to attempt to load it, then keep resetting and pressing start until the game loads. When a game loads successfully, the light stays on a bit longer and flickers a few times. It seems like the cart just randomly fails to load the ROM onto its flash and then freezes.

I am using an RGB-modded IFU-30 (THS7374), with a CoreGrafx and CD-ROM2. If I take the CD-ROM drive out and just run the CoreGrafx, the problem persists. I understand there can be power issues with the TBED, unfortunately I do not have or know anyone with another PC engine to test. I am using an aftermarket power supply from retrogamesupply (marketed for the PCE interface) that outputs a steady 9V according to my multimeter, I also have another 9V PSU I have tried and the original power adapter that I can use with a stepdown (though it outputs 12V so I don't like to use it) and the problem is identical. I have also replaced all electrolytic capacitors in the IFU-30, CoreGrafx and CD-ROM2. I am using No-Intro ROMs and the latest firmware.

Is this a problem anyone is familiar with? It seems strange that it would be a power issue as there seems to be no pattern as to when a game will fail to load, furthermore games that have loaded will run perfectly for as long as I play them. Changing the caps didn't seem to make any difference at all - if it was power I would have expected some change from this at least? Does anyone have any suggestions as to what else I could try, or perhaps has had experience with a similar issue?

Title: Re: TBED - Games don't always start
Post by: FeverDrive on November 24, 2017, 06:13 AM
The hardware mod could be the problem, unfortunately you can't know for sure without testing on a different non-modded console.
Have you tried using another SD card(s)?
Also download your roms from another source.
Title: Re: TBED - Games don't always start
Post by: krisk77 on November 24, 2017, 03:59 PM
Well, tbh, I personally don't rate Retrogamesupply with their PS's, as I ordered some for a Famicom and a PC engine a few months back, which both were generic ebay shit from China.  I had random reboots and some roms not booting on both systems, yet I managed to source original PS's for both consoles and the issues never came back.

Also, make sure the SD is formatted correctly to FAT32/32k/64k clusters and is a branded original card and not a cheap fake.
Title: Re: TBED - Games don't always start
Post by: Kez on November 24, 2017, 06:20 PM
Thanks for the responses. I was also not particularly impressed with the PSUs I received from them, I will probably look elsewhere in future. However, I do also have the original PSU that came with it and have the same problems.

I have tried two SD cards, SanDisk Ultras that I got from Amazon so presumably legit. They work on other Everdrives no problem. I will try some other ROMs, but I am using a well-known and popular pack so I doubt the issue would be there.

The CoreGrafx itself is not modded but unfortunately I do not have a cable for it, I will pick up a DIN5 and make a composite cable, see if I still have issues running it standalone.