EverDrive Forum

General => EverDrive 64 => Topic started by: fluffysorbet on September 09, 2020, 09:42 PM

Title: Road Rash 64 not working?
Post by: fluffysorbet on September 09, 2020, 09:42 PM
Using the US ROM on my Japanese N64. Tried forcing to NTSC and no luck just black screen on booting. Anyone know the trick to getting it working?
Title: Re: Road Rash 64 not working?
Post by: rlstine on September 09, 2020, 09:48 PM
First thing I would suggest is to check a different rom, preferably one from a "no intro" set. If your cart is set to NTSC and it's an NTSC rom it should work so long as it's a good dump.
Title: Re: Road Rash 64 not working?
Post by: fluffysorbet on September 09, 2020, 11:10 PM
Tried a few and all had the same CRC so far, will dig into a few. I did see something about the game having checks but the forcing NTSC was supposed to beat that.

Nope, every ROM seems to have the same CRC. Not sure if it needs a specific combination of options or save set but I can't figure it out.
EDIT: Well, I'm out of ideas.
Title: Re: Road Rash 64 not working?
Post by: CrashOveride on September 11, 2020, 12:21 AM
Which ED64 do you have?
Title: Re: Road Rash 64 not working?
Post by: fluffysorbet on September 12, 2020, 07:45 PM
Just the standard 2.5 version. This is literally the only game I seem to have any problem with. CRC checks as 600B3988, which seems to be the same as everything I can find and passed as being a good dump. Very puzzled.
Title: Re: Road Rash 64 not working?
Post by: Xan on September 12, 2020, 11:54 PM
That ROM worked for me on the X7. Maybe try the new 3.04 OS version.