General > Mega EverDrive

SMS roms with Mega Everdrive Pro on Mega Sg

(1/4) > >>

I'd greatly appreciate any help. I've searched through various posts on here and other sites with no solution or understanding what's causing this problem.

I created a SmokeMonster ROM pack for my Mega Everdrive Pro.
I've been able to get NES, Genesis, and Sega CD ROMs working, yet I cannot get a single Sega Master System ROM functioning on my Mega Sg. It remains on a black screen when I select an SMS ROM.
I've formatted the 400 GB genuine SanDisk Micro SD card in exFAT and 256kb allocation unit size.
The Megakey setting is set to OFF.
I've tried with Mega Sg v4.7 firmware, and also with the jailbreak v7.7 firmware. No luck.
I've tried smaller micro SD cards in exFAT and FAT32 formats with only SMS ROMs.
I've tried with and without several different SMS BIOS files in the MEGA/bios folder.
There was a solution in 2019 about first selecting the SMS ROM, running Ultracore, then returning to the cartridge. Didn't work for me.

It's clear I've overlooked something. If anyone can make any suggestions, I'd be grateful.
Thank you.

*****UPDATE: I tested the MED Pro on a Sega Genesis Model 1. I was able to play the SMS ROMs. Therefore, I've concluded the problem lies with the Mega Sg. I'll follow-up with Analogue.

Are the SMS roms also from a SmokeMonster or no-intro pack?
What is the file extension for your SMS roms? I think it should be ".sms".
The roms can't be inside the MEGA folder.

If nothing works it might be a problem with the Mark III mode of your Mega Drive. Does SMS games work using a Power Base Converter or similar adapter? The Phantasy Star 1 MD cartridge also counts as an SMS game in an adapter, if you by any chance happens to have that game.
Try cleaning the console's cartridge slot with isopropyl alcohol. The Mark III mode pin might be dirty. Check so there isn't a resin blob or anything on the Everdrive's connector.

Thank you for responding and offering help.

The SMS ROMs have the correct ".sms" extensions and are not in the MEGA folder. I created the Master Everdrive version of The SmokeMonster packs and everything was verified through it's script.

Do you mean that you believe the problem may be in my Analogue Mega Sg? I don't have a Mega Drive/Genesis. I received the console last year, yet I finally took it out of the box to test earlier this week to enjoy.

When I arrive home later, I'll follow your suggestions by checking the pins on the Everdrive connector. The Everdrive is also new. I'll also check the pins on the console as well.
I'll pick up an SMS cartridge or the Phantasy Star you've suggested.
I guess I'll look for somebody in my area that can test my MED Pro on their Genesis/Mega Drive console. That might be a challenge.

I missed that you had a Mega SG. Yes that's probably the problem. Everdrives often has problems with modern clones.

Both the console and Everdrive are so new that I doubt the pins are dirty already, but I remember before that someone had a drop of resin on their Everdrive from the production.

The Phantasy Star game is a Japanese exclusive and not cheap, so it's a bit much to pick up just to test with.

Sega Master System games run fine on my Mega Everdrive Pro on Mega SG
i tested
Street Fighter 2
Sonic 1


[0] Message Index

[#] Next page

Go to full version