Author Topic: Having issues with my GBAED - stuck on GBA launch screen  (Read 3524 times)

0 Members and 1 Guest are viewing this topic.

Offline Jmbarnes101

  • Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Having issues with my GBAED - stuck on GBA launch screen
« on: January 02, 2017, 07:47 AM »
So I put a 32GB Kingston Flash card in my GBA ED and loaded the system files and some roms, from Smokemonsters set. When I first turned it on it played through the GBA launch screen to a white screen. It did nothing so I let it sit for about 10 minutes to see what would happen. It never changed so I turned it off and tried it again. Now, whether I have an SD card loaded or not it freezes on the launch screen. It says Game Boy and just sits there. Has anyone had this happen and is there a way to fix it? I've never had an issue with an Everdrive before but this one is becoming the exception.

Offline Shadow666

  • Hero Member
  • *****
  • Posts: 515
  • Karma: +15/-0
    • View Profile
Re: Having issues with my GBAED - stuck on GBA launch screen
« Reply #1 on: January 02, 2017, 12:39 PM »
Now it's past the white screen to an orange/red, I can't determine certain colors, screen and is stuck there instead.

Learn to update your first post with the info insted of making new posts

Offline fille1976

  • Sr. Member
  • ****
  • Posts: 355
  • Karma: +13/-0
    • View Profile
Re: Having issues with my GBAED - stuck on GBA launch screen
« Reply #2 on: January 02, 2017, 03:47 PM »
original games works on your gba?

Offline wolfpacleader1986

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +2/-1
    • View Profile
Re: Having issues with my GBAED - stuck on GBA launch screen
« Reply #3 on: April 12, 2017, 06:51 PM »
Same thing happens to me, but after a few power cycles, it works. Not sure why that is. I'm using a Sandisk 32GB Ultra MicroSD card

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: Having issues with my GBAED - stuck on GBA launch screen
« Reply #4 on: April 12, 2017, 08:09 PM »
Have you tried to setup another SD card?