General > Joyzz

Seems to completely have stopped working 2 years after purchase - WORKING NOW


[EDIT] I dunno why, but it's working again now.  I let it charge again for a few hours and now it connects fine with no drops.  Strange!

I had not used my Joyzz for a few months, but left it plugged into a charger.  I decided to play some games on my Mega SG last night, and Joyzz worked fine for a few seconds, then dropped its connection (red solid light on receiver).  Resetting the Mega SG would just cause the same thing.  I then tried re-syncing by pressing the button on the receiver, but the Joyzz would not sync after pressing the appropriate button combination (I waited 10-15 seconds).  After that, it would not connect at all.

I let it charge overnight, but this didn't help.

Next, I installed the CP210x drivers and ran jconfig, but it just tells me "Joyzz is not detected".  I tried three different cables, all of which I know are data cables, connected directly to my PC but I still cannot detect Joyzz.  When I connect Joyzz, my PC does detect that a USB device was connected.

Is the battery completely dead?  I would be surprised if this was the case, as I've probably used the Joyzz only less than 25 hours total over two years.  Is there anything else I should try?


[0] Message Index

Go to full version