Author Topic: @Krikzz - Late SD2SNES vs Early Pro having glitches  (Read 1560 times)

0 Members and 1 Guest are viewing this topic.

Offline teknomedic

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
@Krikzz - Late SD2SNES vs Early Pro having glitches
« on: August 29, 2020, 08:29 AM »
@Krikzz
I've posted a few recent threads concerning some issues I've been having with some games using my SD2SNES Pro (I bought during the short time before the name change to FXPak Pro).  A few months before the release of the Pro version I also bought latest and greatest board revision of the SD2SNES.  Due to circumstances I never got around to using the SD2SNES... and further circumstances I couldn't use the Pro version until recently (hence my recent posts).

1) I noticed some graphic glitches in Super Mario RPG (my other thread has a picture of the issue), I had geometry glitches (could walk through some walls) as well as a full game crash which put me to a static like glitch screen which also happened to erase my save games by simply going down a pipe.
2) Top Gear 3000 also ran into a screen coloring issue after playing a few levels though I think it was only on the general map screen.
3) In my limited testing I ran into MSU-1 with FMV issues where the FMVs were messed up... though I resolved that by re-installing the firmware.
4) There's also an issue where if I sit in the Analogue Super NT's main menu too long (30 seconds to a minute?) then I can't boot the SD2SNES Pro as it just goes to a blank screen (though accessing the Super NT menu is still possible).  BTW, If I load the SD2SNES Pro quickly enough after booting my Super NT, then all is well (no blank screen).

Since those posts I decided to take my Micro SD card with ZERO changes and simply put it into the older SD2SNES I still have..... So I have a situation where...
1) The same SD card is being used (although with an adapter)
2) The same console is being used (Analogue Super NT)
3) The same console firmware (latest jailbreak) & same SD2SNES firmware (latest official) are being used
4) The same ROMs are being used
5) The same saves are being used
6) All the same settings on SD2SNES and Super NT are being used

.... and yet... ALL the glitches are gone.  I can't make Super Mario RPG graphics glitch anymore, Top Gear 3000 is running normally, the FMVs are working on first try AND I can sit in the Super NT's menu as long as I want and still boot to the SD2SNES.

There seems to be some issues with the first version SD2SNES Pro as I've seen other posts related to similar issues here and on other forums.

Both Super Mario RPG and Top Gear 3000 use different special chips... so maybe the general firmware is OK, but there's an issue with how the new FPGA is trying to use the special chip files??

Is this a case of needing better firmware for the SD2SNES Pro... or is this something that's not fixable and I need to exchange for a later board revision (if there even is one yet).  Is there any other testing I can do to help you sort out these issues?


edit... I did also run into some issues with Zelda A Link to the Past on the Pro vesrion as well, but because I was using a hacked MSU-1 with FMV and some interface changes I chalked those up to the hack vs the Pro... nothing too serious... mostly some odd running too fast up or down stairs/ladders where one time I got stuck in wall.  At any rate I feel it's best to avoid using my SD2SNES Pro at this time until the issues are fixed or I manage to exchange it (probably very difficult to do as I bought from Stone Age Gamer and it's been a few months.)
« Last Edit: August 29, 2020, 08:58 AM by teknomedic »

Offline zaphro72

  • Full Member
  • ***
  • Posts: 204
  • Karma: +8/-0
    • View Profile
Re: @Krikzz - Late SD2SNES vs Early Pro having glitches
« Reply #1 on: August 30, 2020, 01:22 AM »
Krikzz doesn't do the firmware for the FXPak Pro. That question would likely be better put forward to Ikari.

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Hero Member
  • *****
  • Posts: 666
  • Karma: +11/-0
    • View Profile
Re: @Krikzz - Late SD2SNES vs Early Pro having glitches
« Reply #2 on: August 30, 2020, 01:51 AM »
That's an interesting topic to bring up and I was always wondering how it's possible to even know which was the very 1st SD2SNES to the finalized one as it's hard to tell the differences outside of the revision on the information options. But as firmware can always be updated it likely is impossible to tell unless you unscrew the parts and see inside the thing itself.

I really couldn't tell what version I have and I own two variants of the SD2SNES and 3 of the Super Everdrives, none have that issue you mentioned on those games but likely mine are much later revisions of the device itself.

The only one I can remember is the original Super Everdrive that still had the windows 95 type loading screen with the green bar, later ones omitted it and just had bytes on how much was loaded while the final omitted it entirely.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline teknomedic

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: @Krikzz - Late SD2SNES vs Early Pro having glitches
« Reply #3 on: August 30, 2020, 04:04 AM »
There are board revisions printed on the PCBs of the Everdrives.  I'd have to look it up, but I think the last revision of the SD2SNES before the switch to the updated FPGA on the Pro version was "J".

I know when I ordered I had the latest board revision, then shortly after the SD2SNES Pro was released which is when I bought again... then of course the name change to FXPak Pro... unsure if there have been any board revisions related to that though as I haven't looked into it.

Offline teknomedic

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: @Krikzz - Late SD2SNES vs Early Pro having glitches
« Reply #4 on: August 30, 2020, 04:05 AM »
Krikzz doesn't do the firmware for the FXPak Pro. That question would likely be better put forward to Ikari.

Does that person frequent here... or should I seek them out on another forum??

Offline Relikk

  • Sr. Member
  • ****
  • Posts: 406
  • Karma: +35/-8
    • View Profile
Re: @Krikzz - Late SD2SNES vs Early Pro having glitches
« Reply #5 on: August 30, 2020, 10:07 PM »
You'd be better off catching ikari at the Classic Gaming Discord server, in the FXPak channel.