Author Topic: FXPAK Pro does not boot  (Read 301 times)

0 Members and 1 Guest are viewing this topic.

Offline Jay XIV

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
FXPAK Pro does not boot
« on: April 15, 2021, 03:15 AM »
Hello,

I have an FXPAK Pro purchased from everdrive.me that does not boot up anymore. It worked fine until recently. I used it about 2 months ago and decided to play some games again to no avail. All I ever get is a black screen.
I am using a Super NT with the latest firmware 5.0.
Other carts work fine. I tried 4 different games (2 NTSC, 1 PAL, 1 NTSC repro) and all worked without any issue.
All I get is a black screen when I select "Run Cartridge" in the Super NT menu. I have tried 3 different SD cards, reformatted (FAT32, default allocation), reinstalled the firmware, tried an older firmware, updated my Super NT firmware (I was previously running 4.5 which I updated to 5.0), tried a different power brick; all I ever get is a black screen and the 3 solid LEDs (green, yellow, red) at the same time.
I tried the diagnostic firmware on all 3 different SD cards. All I get is an LED that briefly blinks to green and disappears. No log is generated.
I do not have a regular SNES to try it on.
I am out of ideas.
Any help would be greatly appreciated.
« Last Edit: April 17, 2021, 01:30 AM by Jay XIV »

Offline Jay XIV

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: FXPAK Pro does not boot
« Reply #1 on: April 16, 2021, 12:52 AM »
I realized the SD2SNES diagnostic firmware is no good for FXPAK Pro (not easy to find that info) so I switched to the SD3SNES diagnostic firmware and I got a log.

===log opened===
flash check:   1d62b458-b82d6850-c2-11-0 
SD test... please insert card
=============================
crc1 = 8a0b9767 crc2 = 8a0b9767   PASSED


RTC Test
========
setting clock to 2019-02-23 00:00:00
2019-02-23 00:00:00
waiting 2 seconds
new time: 2019-02-23 00:00:02
PASSED


FPGA test
=========
configuring fpga...
basic communication test...PASSED


RAM connection test
===================

Testing RAM0.1 (U501)...

Testing RAM0.2 (U502)...

Testing RAM1 (U511)...
PASSED

SD DMA test
===========
clearing RAM - loading test file - verifying -PASSED


Loading SNES test ROM
=====================



sysclk test
===========
measuring SNES clock...
21477701 Hz
21477701 Hz diff = 0  max = 0
21477697 Hz diff = 4  max = 4
21477694 Hz diff = 3  max = 4
   CPUCLK: 2823147
  READCLK: 1954486
 WRITECLK: 0
  PARDCLK: 0
  PAWRCLK: 0
  REFRCLK: 78730
ROMSELCLK: 0
   CICCLK: 3579616
** /PARD ERROR. CHECK RAM TEST, SNES TEST, RA109, U103, FPGA pin B9
** /PAWR ERROR. CHECK RAM TEST, SNES TEST, RA109, U103, FPGA pin C9
** /WRITE ERROR. CHECK RAM TEST, SNES TEST, RA102, U101, FPGA pin K2
** ROMSEL ERROR. CHECK RAM TEST, SNES TEST, RA103, U102, FPGA pin C2
** CONTROL SIGNAL ERRORS DETECTED. See above errors
   and check all RA, FBA, U101-103 connections.
FAILED


SNES test status: IRQ: 00   PA: 00   MEM: 00/00
** SNES CPU ERROR. CHECK RAM TEST, CLK TEST, FBA101, FBA102, RA103-109, RA121-122, U101-103, FPGA



TEST SUMMARY
============

flash check:   1d62b458-b82d6850-c2-11-0 
Test      Result
----------------
SD        Passed
USB       not implemented
RTC       Passed
CIC       no run
FPGA      Passed
RAM       Passed
SD DMA    Passed
CLK       FAILED
DAC       not implemented
SNES IRQ  no run
SNES RAM  no run
SNES PA   FAILED