EverDrive Forum

General => EverDrive GB => Topic started by: deadl0ck on June 09, 2021, 06:37 PM

Title: GB Seems to be screwed since using X7
Post by: deadl0ck on June 09, 2021, 06:37 PM
I got my Everdrive GB X7 from dragonbox.de today.
I have original DMG-01 Gameboy and it has an IPS screen, and I also have the CleanJuice USB-C Battery pack so lost of power.
This had been working fine with original carts and an old clone ED I tried belonging to a  friend (to make sure it would work) so I decided to get the X7 due to the save state support

I played a little bit of Castlevania - Belmont's revenge and created a save state - then on using the save state the game crashed after about 30 seconds with the GB rebooting with garbled Nintendo logo. To be sure it wasn't power I charged the battery pack and tried again - no joy again.
The the screen wouldn't turn on, now it won't boot an original cart even.
I can hear some weird noises from the speaker if I hold my ear very close, and the little buzz that it's on - the LED light is also on - but apart from that no life.
Won't work with original carts, or with no cart.
Any ideas ?? :-\
Title: Re: GB Seems to be screwed since using X7
Post by: FeverDrive on June 10, 2021, 06:42 AM
Perhaps the GB power supply blew up?
Title: Re: GB Seems to be screwed since using X7
Post by: deadl0ck on June 10, 2021, 11:33 AM
Maybe - interesting - I can still see the battery LED and there is a very small noise from the speaker but if the power supply was compromised I guess they could still work without  the display working....
Hmm...
I have my original Gameboy unmodified - I could try the display in it as a test....
Thanks
Title: Re: GB Seems to be screwed since using X7
Post by: deadl0ck on June 21, 2021, 10:25 PM
So instead of risking my original GB from back in the day I bought a CleanPower V2 Power Regulator from RetroSix: https://retrosix.co.uk/CleanPower-V2-Game-Boy-Original-p141361110
Still the same, so obviously not the power regulator :/