Author Topic: Eye of the beholder mouse support is broken  (Read 3778 times)

0 Members and 1 Guest are viewing this topic.

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Eye of the beholder mouse support is broken
« on: July 19, 2017, 07:50 AM »
The cursor just drifts to right side of the screen and isn't usable. My SNES mouse works fine on all other mouse enabled games. (im using latest OS for the sd2snes)
« Last Edit: July 19, 2017, 07:56 AM by Tzakiel »

Offline Great Hierophant

  • Sr. Member
  • ****
  • Posts: 298
  • Karma: +20/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #1 on: July 19, 2017, 09:01 AM »
Works fine for me, make sure your in-game hooks are off.
Check Out My Vintage Video Game & Computing Blog : http://nerdlypleasures.blogspot.com/

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #2 on: July 19, 2017, 09:07 AM »
Are you using the original nintendo brand mouse or the hyperkin made one? I'm using hyperkin, that might be the problem. Though it works fine in all other mouse games.

Offline Great Hierophant

  • Sr. Member
  • ****
  • Posts: 298
  • Karma: +20/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #3 on: July 19, 2017, 03:10 PM »
I'm using Nintendo's original.  I knew that the Hyperkin mouse had been announced, but I was not aware that it was released.  However, my original point about the in-game hooks still stands.  With the hooks on and the latest OS 0.1.7e, my mouse will not really move at all in EOB but works fine with Mario Paint.  With the hooks off, my mouse moves normally in EOB.

Are you using a 1-Chip SNES or SNES mini/jr?
« Last Edit: July 19, 2017, 03:52 PM by Great Hierophant »
Check Out My Vintage Video Game & Computing Blog : http://nerdlypleasures.blogspot.com/

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #4 on: July 19, 2017, 04:19 PM »
Thanks, I'll try to turn the hooks off. I'm using an original NA model snes.

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #5 on: July 19, 2017, 05:05 PM »
Well I set in game hook to "off" and then mouse still doesn't function other than some random erratic movement in this one game.

Offline Great Hierophant

  • Sr. Member
  • ****
  • Posts: 298
  • Karma: +20/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #6 on: July 19, 2017, 09:03 PM »
You disabled all three functions, the Hook, the Buttons and the Holdoff?

There is a button on the underside of the Hyperkin mouse, I believe it should set the polling rate.  The original SNES mouse has no such button.  Try different settings, that may fix the issue.

I have the original EoB cart, but I can't afford the Hyperkin mouse right now.
Check Out My Vintage Video Game & Computing Blog : http://nerdlypleasures.blogspot.com/

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #7 on: July 19, 2017, 09:12 PM »
Oh I didn't realize any of those things could help. I'll check them out.

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Eye of the beholder mouse support is broken
« Reply #8 on: July 19, 2017, 10:31 PM »
Turned all 3 settings off, tried clicking the hyperkin button a few times, all same results. Looks like hyperkin shat the bed.