Author Topic: Mega Everdrive x3 and Sega 32X Problems - Don't Load Any ROM (reset after load)  (Read 441 times)

0 Members and 1 Guest are viewing this topic.

Offline kuroneko666

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Hello, guys!

Someone has this problem before?

I have an Everdrive X3 (Model 16, Rev. A, 2016.09.27) since 2019 and wanted to play Virtua Racing Deluxe via Sega 32X again.
I had an Everdrive v3 before X3 and runs flawlessly, but I sold it.
Since I've bought this X3, never tried to load any ROMs with the 32X attached.

The Everdrive X3 is running any games without problems, directly attached on Mega Drive 3 and Mega Drive 2 (Brazilian models).

If I try to load any ROM with the Sega 32X attached, it will show the "Loading" message, and apparently give a "reset" after this.

Neither Sega 32X or Sega Genesis/ Mega Drive ROMs load...
Trying to play 32X or Genesis cartridges attached via Sega 32X, runs without any issues.


Here are some photos. I've tried update the OS and the problems still persists...