Author Topic: SRAM ERROR 01  (Read 3295 times)

0 Members and 1 Guest are viewing this topic.

Offline MaarioS

  • Newbie
  • *
  • Posts: 46
  • Karma: +2/-0
    • View Profile
SRAM ERROR 01
« on: September 15, 2016, 11:56 PM »
Hi there. My Everdrive N8 recently died unfortunately. First of all, I purchased it directly from Krikzz shop website a few years ago so it is original. I remember a few instances when it freezed a game for no reason and once I did SELECT+START+B+A test, it threw SRAM ERROR but after a while, for some reason SRAM test passed OK and it played games again.

Not after some time when I wanted to play my Everdrive, it constantly gave SRAM ERROR on test screen and it doesn't work at all.

I've received 10x new SRAM chips that are exactly the same, IS62LV1024-55H and soldered it on the board. Strangely enough it gives SRAM TEST ERROR as well. At first, it was SRAM TEST ERROR 03 but after some tries, it gave SRAM TEST ERROR 01 (I don't know what the difference is anyway). So after that, I changed the SRAM chip again and it gave SRAM TEST ERROR 01 again, so I really doubt it is actually SRAM chip issue at all. But if not that, so what is?? Can anyone give me any suggestions what's going on?? Can my Everdrive be repaired anymore?? Please for help and response. Many thanks in advance!!

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3385
  • Karma: +514/-2
    • View Profile
Re: SRAM ERROR 01
« Reply #1 on: September 16, 2016, 04:04 PM »
It could be cold soldering points on fpga contacts or something in ram power supply circuit

Offline MaarioS

  • Newbie
  • *
  • Posts: 46
  • Karma: +2/-0
    • View Profile
Re: SRAM ERROR 01
« Reply #2 on: September 16, 2016, 04:08 PM »
Can you provide me some schematic of the Everdrive and point out which parts might need replacement?? Is it possible that FPGA is broken and it will need replacement?? Can I repair it if that is the case??

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3385
  • Karma: +514/-2
    • View Profile
Re: SRAM ERROR 01
« Reply #3 on: September 16, 2016, 06:03 PM »
fpga is not broken for sure. In such cases i just resolder all pins

Offline MaarioS

  • Newbie
  • *
  • Posts: 46
  • Karma: +2/-0
    • View Profile
Re: SRAM ERROR 01
« Reply #4 on: September 16, 2016, 07:07 PM »
YAY, I just resoldered all the joints on the FPGA and guess what?? Right after I turned on the Everdrive, it didn't work but once I ran the test screen, SRAM TEST was OK and after that, my Everdrive started to work again!! Many thanks for the guess!!

Also, this is kinda weird- are cold solder joints common in Everdrives?? So is the factory soldering not so good in it??

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: SRAM ERROR 01
« Reply #5 on: September 23, 2016, 04:10 AM »
YAY, I just resoldered all the joints on the FPGA and guess what?? Right after I turned on the Everdrive, it didn't work but once I ran the test screen, SRAM TEST was OK and after that, my Everdrive started to work again!! Many thanks for the guess!!

Also, this is kinda weird- are cold solder joints common in Everdrives?? So is the factory soldering not so good in it??

Sometimes the environment corrodes the soldering joints
WELCO
METOT
HENEX
TLEVEL