General > Master EverDrive

Master Everdrive and Sega Mark III

(1/2) > >>

dudutop:
Hello Everybody !

I am new on this forum, and I need help about Master Everdrive ...
I have a Sega mark III, I bought an adaptator SMS to Mark III, but
when I plug the masterED in it, it doesn't work ...
My masterED is working with OS 8.
I have read some informations on this forum, and apparently a downgrade
is required, to OS 5 ? How can I perform this ? Or is there another solution ?

Thank you for helping !

D.Lo:
Yes you need to downgrade to OS version 5.

It works fine, 100% compatibility, see here:

http://nintendosegajapan.com/2015/03/13/creation-of-a-sega-mark-iii-everdrive-flash-cart/

To downgrade, just add the firmware to your SD card, name the file extension .mso and load it.

dudutop:
@D.Lo,

Thank you for reply ! I will try this method soon,
and I hope it will work fine !

kapitostes:
Hi, sorry for refloating this post.
I wanted to know if the everdrive cartridge in Mark III worked this way.

I have also read about a mod that was changing a plate capacitor.

Greetings and thank you.


keeper7:

--- Quote from: kapi21 on January 19, 2020, 05:31 PM ---Hi, sorry for refloating this post.
I wanted to know if the everdrive cartridge in Mark III worked this way.

I have also read about a mod that was changing a plate capacitor.

Greetings and thank you.

--- End quote ---

Have you tried os-v9.mso?
I'm asking because I have a japanese Master System and MasterED only works with os-v5.mso and os-v9.mso using that system.
Since Mark III is more or less a japanese Master System, maybe a downgrade isn't necessary.

Navigation

[0] Message Index

[#] Next page

Go to full version