Author Topic: Mega EverDrive Pro - ERROR:05  (Read 689 times)

0 Members and 1 Guest are viewing this topic.

Offline SSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Mega EverDrive Pro - ERROR:05
« on: April 24, 2021, 04:36 AM »
Hi! I got a Mega EverDrive Pro today, but for some reason, I've been having problems with it. I'm using a real unmodded Model II Genesis that is connected to a real CD and 32X.

I do the instructions as told, but once I boot up the Everdrive and the menu appears, I notice that the folder names I have are messed up, consistently the first couple of letters (i.e. "MEGA" appears as "UEGA"). Pressing the start button on the main menu gives me "ERROR:04 - file not found". Every time I turn the console off, then on, I notice that the folder names will see a random letter change every now and then. I'm assuming that it's the SanDisk 16GB Ultra microSDHC UHS-I cards that I've been using, as other than "???" on the cart type (hich is odd because it can detect the cart date no problem), the diagnostics test turned up fine. It's even detecting the recent OS version, despite me not even being able to access the file through the cartridge, although it keeps telling me on every boot-up that the settings got changed to default.

I've been trying out other Sandisk Ultra microSDHC cards of varying sizes and nothing better. I've tried formatted them from FAT32 to exFAT via Windows 10, and upped their file allocation and the problem continues. The only solution I can think of is to get cards from a different company, like Samsung, because it being a Sandisk Ultra is somehow the cause. Does anyone have an idea on what the problem is?
« Last Edit: April 24, 2021, 07:34 AM by SSF »

Offline SSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Mega EverDrive Pro - ERROR:05
« Reply #1 on: April 24, 2021, 09:42 AM »
Out of curiosity, I tried doing an overwrite format to FAT32 and 32k file clusteer size via SD Card Formatter, and nothing.

I think it's still able to detect the OS files like normal because going into the MEGA (it's being displayed as eEGA on the menu) actually lets me "look" at the files...sometimes, when it lets me after I turn the console off and on. It's not consistent, but it does happen fairly often. But the OS sub-folder list, as I'm looking at it right now as I'm typing this, displays like this:

biUsU
edap
UpU-msU
UpU-Utd
UaUperU
UaUeU
UyU
UyUcUre
Uhemes
Uegaos.dat

I can't access any of these. but the .dat file lets me see the file info's size (256kb), date (February 10th of this year, around the date of the last firmware update), and the time. Trying to access the other folders means that I just get the "ERROR:04 - file not found" message that I can't back out from. My GAMES folder, sitting outside the MEGA folder as instructed, is displaying as "GAUE", for some reason. It looks like everything else in the menu is fine. I can easily read dianostics information just fine. The cheats menu looks okay too. The only thing acting up are the names of the folders/files, and the ability to access them so I can try out games and turn on the themes.
« Last Edit: April 24, 2021, 09:51 AM by SSF »

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 996
  • Karma: +55/-0
    • View Profile
    • gamehacking.org
Re: Mega EverDrive Pro - ERROR:05
« Reply #2 on: April 24, 2021, 03:53 PM »
try everdrive without 32x and cd connected
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
RetroUSB AVS | Super NT | Mega SG | Super Retro Advance |  16bitPocket GBC | PCE+SSD3

Offline zaphro72

  • Full Member
  • ***
  • Posts: 204
  • Karma: +8/-0
    • View Profile
Re: Mega EverDrive Pro - ERROR:05
« Reply #3 on: April 24, 2021, 06:04 PM »
I would also use exFAT for the formatting of the SD card as it appears to work better with CD games then FAT32

Offline SSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Mega EverDrive Pro - ERROR:05
« Reply #4 on: April 24, 2021, 09:46 PM »
try everdrive without 32x and cd connected

Okay, so there has been progress, thanks to you suggesting this!

The Everdrive works on my Genesis by itself.
The Everdrive works on my Genesis and the CD.
It doesn't work on the Genesis and the 32X.

So, it's some kind of incompatibility of my 32X. Is there an issue with certain 32X revisions?

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 996
  • Karma: +55/-0
    • View Profile
    • gamehacking.org
Re: Mega EverDrive Pro - ERROR:05
« Reply #5 on: April 25, 2021, 07:07 AM »
used 32x unit have loose ribbon cable and some model have daughter board aged badly
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
RetroUSB AVS | Super NT | Mega SG | Super Retro Advance |  16bitPocket GBC | PCE+SSD3

Offline SSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Mega EverDrive Pro - ERROR:05
« Reply #6 on: April 25, 2021, 07:23 AM »
used 32x unit have loose ribbon cable and some model have daughter board aged badly

Right. It sounds like I'll have to get a new one then.