Author Topic: SD2SNES not working after being put into cartridge slot backwards  (Read 1906 times)

0 Members and 1 Guest are viewing this topic.

Offline Uzerro

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
So I've had my sd2snes for 2 or 3 years and never had any problems. Today I tried to use it on a friends snes, and since he has a US snes and my sd2snes is in a japanese shell, I took it out of the shel to fit it in the system. I have done this many times before without any problems. However, this time
I was doing so in the dark and plugged it in backwards without realizing and turned the system on. After seeing that it was backwards, I turned it around tried again. Now it wont work at all. No image, no lights on, nothing. I hope I haven't totally fried it and there is some way to fix it, so if you know anything that could help j would appreciate it. I cant find anything pertinent to my problem on google, but I'll be looking in the meantime while I await a response.

Offline husan93

  • Newbie
  • *
  • Posts: 11
  • Karma: +2/-0
    • View Profile
Re: SD2SNES not working after being put into cartridge slot backwards
« Reply #1 on: January 01, 2020, 09:56 AM »
It's very likely that the fuse inside the snes is blown. Do you have any equipment to test the fuse?
Did you test your sd2snes in another SNES to see if at least the cart still works?

Offline Uzerro

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: SD2SNES not working after being put into cartridge slot backwards
« Reply #2 on: January 01, 2020, 10:24 AM »
Sorry if it wasnt clear, but I meant the lights on the sd2snes wont turn on. The system still works totally fine and I've replaced a fuse in one before so that wouldnt be a problem. It is only the flash cartridge that is not working. I cant see any fuse inside the cart that could be the problem, but I haven't had the time to take a good look over the PCB for that yet.

Offline ikari_01

  • Sr. Member
  • ****
  • Posts: 325
  • Karma: +80/-0
    • View Profile
Re: SD2SNES not working after being put into cartridge slot backwards
« Reply #3 on: January 02, 2020, 02:57 PM »
Hmm, sd2snes should have some protection against inverse polarity unless you connect any other grounded cables to it (e.g. USB) but it's probably not bullet proof. Q301 is supposed to conduct only if polarity is correct. It is located near the cart slot edge on the side of the PCB normally facing front. When inserted and powered up, the top left pin (near the "C111" printing) should have 5V. If you don't get any voltage there, check the input (single bottom pin of Q301). If there isn't anything either, L391, a bit to the right, may have burnt out (or it was shaved off by the cartridge slot lid on the SNES).
« Last Edit: January 02, 2020, 03:00 PM by ikari_01 »

Offline Uzerro

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: SD2SNES not working after being put into cartridge slot backwards
« Reply #4 on: January 27, 2020, 01:06 AM »
Alright, this a bit late, but I finally got a chance to sit down and work on this. Looks like the problem is probably L391, since it looks like its burnt out. Any chance you could point me in the direction of where to find a replacement component?