EverDrive Forum

General => Mega EverDrive => Topic started by: mario64 on October 29, 2020, 10:00 PM

Title: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on October 29, 2020, 10:00 PM
Just got my MED Pro and immediately ran into problems. Loaded up Virtua Racing. Selecting a regular game works but Free Run doesn't. If you choose Free Run it hangs. Have to cycle power to get back to the menu. KRIKzz could you please take a look?
Title: Re: Virtua Racing hangs on MED Pro
Post by: lee4 on October 29, 2020, 10:57 PM
I have Mega Everdrive Pro Virtua Racing both modes work fine
but on Mega Everdrive X7 Virtua Racing the Free Run mode freezes (http://krikzz.com/forum/index.php?topic=9583.msg72625#msg72625)
Title: Re: Virtua Racing hangs on MED Pro
Post by: mario64 on October 29, 2020, 11:02 PM
I have Mega Everdrive Pro Virtua Racing both modes work fine
but on Mega Everdrive X7 Virtua Racing the Free Run mode freezes (http://krikzz.com/forum/index.php?topic=9583.msg72625#msg72625)
Not me. Which specific rom file are you using?
Title: Re: Virtua Racing hangs on MED Pro
Post by: lee4 on October 29, 2020, 11:07 PM
Virtua Racing (U) [!]
SHA1: FF969AE53120CC4E7CB1A8A7E47458F2EB8A2165
Title: Re: Virtua Racing hangs on MED Pro
Post by: mario64 on October 29, 2020, 11:21 PM
Virtua Racing (U) [!]
SHA1: FF969AE53120CC4E7CB1A8A7E47458F2EB8A2165
I'm using the exact same file and cannot play Free Run mode
Title: Re: Virtua Racing hangs on MED Pro
Post by: lee4 on October 29, 2020, 11:29 PM
which model system you are using ?
Title: Re: Virtua Racing hangs on MED Pro
Post by: mario64 on October 29, 2020, 11:43 PM
which model system you are using ?
Mega SG on latest firmware. FWIW, the same rom works correctly on a Mega SD
Title: Re: Virtua Racing hangs on MED Pro
Post by: lee4 on October 29, 2020, 11:52 PM
my setup also

Mega SG FW 4.7
MED Pro OS 4.07
Title: Re: Virtua Racing hangs on MED Pro
Post by: brianvgplayer on October 30, 2020, 03:02 AM
It's a Mega SG specific issue. It did the same thing on V2/X7.
Title: Re: Virtua Racing hangs on MED Pro
Post by: mario64 on October 30, 2020, 03:10 AM
It's a Mega SG specific issue. It did the same thing on V2/X7.
Interesting. Wonder why it works on Mega SD though?
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on October 30, 2020, 08:31 PM
Confirmed this is an incompatibility between MED Pro and Mega SG for this game. Still needs to be fixed though as Mega SD does not have this issue. @KRIKzz?
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: lee4 on October 30, 2020, 08:48 PM
using Pro work fine for me
with X7 i confirmed broken
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on October 30, 2020, 08:58 PM
using Pro work fine for me
with X7 i confirmed
You're testing Free Run mode?
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: lee4 on October 30, 2020, 09:27 PM
using Pro work fine for me
with X7 i confirmed broken
You're testing Free Run mode?
yes
tested free run mode

Mega SG i have boot direct to cartridge
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on October 30, 2020, 10:32 PM
using Pro work fine for me
with X7 i confirmed broken
You're testing Free Run mode?
yes
tested free run mode

Mega SG i have boot direct to cartridge
Tried to send you a PM but it shows blocked
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on November 01, 2020, 04:25 AM
Anyone besides lee4 able to play Free Run mode on MED Pro using Mega SG?
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: KRIKzz on November 04, 2020, 05:31 PM
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on November 04, 2020, 07:59 PM
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: KRIKzz on November 05, 2020, 01:15 PM
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

It fixable for sure but so far i have no ideas how to track it down, i tried but without success. May be it even not directly related to SVP core itself, for example while ago i fixed bug related to soft reset cmd which rarely used by games, only few known games uses it at startup. On MegaSG with Mega-pro those games just hangs, but worked fine with MegaSD. After all i found that MegaSG core has a bug which causes this problem: after soft reset cmd MegaSG begins fetching data from cart before than reset signal actually was released, but cart isn't response because reset still asserted by the console. At same time this behavior does not have any effect for MegaSD, likely because MegaSD does not return to menu after reset and reset signal not affect the cart whatever happens wit it. I was able to fix this problem on my side but this case explains why sometimes hard to have deals with clones, original systems also may have some bugs but they documented at least, but in case of clones usually no any info.

While I was writing this message, I got an idea that i should check if described above behavior isn't affect VR also. Hm...
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on November 05, 2020, 04:31 PM
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

It fixable for sure but so far i have no ideas how to track it down, i tried but without success. May be it even not directly related to SVP core itself, for example while ago i fixed bug related to soft reset cmd which rarely used by games, only few known games uses it at startup. On MegaSG with Mega-pro those games just hangs, but worked fine with MegaSD. After all i found that MegaSG core has a bug which causes this problem: after soft reset cmd MegaSG begins fetching data from cart before than reset signal actually was released, but cart isn't response because reset still asserted by the console. At same time this behavior does not have any effect for MegaSD, likely because MegaSD does not return to menu after reset and reset signal not affect the cart whatever happens wit it. I was able to fix this problem on my side but this case explains why sometimes hard to have deals with clones, original systems also may have some bugs but they documented at least, but in case of clones usually no any info.

While I was writing this message, I got an idea that i should check if described above behavior isn't affect VR also. Hm...
Very interesting. Thanks again. I'm happy to help test or anything else you need to try and track it down.
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on November 20, 2020, 04:49 AM
This remains an issue in 4.08
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on February 01, 2021, 05:33 PM
Still not fixed in 4.09  :(
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: LeoLion on February 03, 2021, 01:31 AM
I can also confirm that this isn’t fixed on firmware 4.09 using my Mega Sg.
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: lee4 on February 07, 2021, 12:04 PM
Quote from: krikzz
@analogue
 I found some bugs is Mega-SG core and reported them at Mega-Sg-Jailbreak github repo. Both not affected everdrive anymore but could be useful to fix it for overall compatibility improvement.
https://twitter.com/krikzz/status/1358030810109145090
https://github.com/SmokeMonsterPacks/Mega-Sg-Jailbreak/issues/90
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: KRIKzz on February 08, 2021, 12:54 AM
Fix will be included in OS v4.11
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on February 08, 2021, 01:10 AM
Fix will be included in OS v4.11
Awesome! Thank you  :)
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: mario64 on February 10, 2021, 09:06 PM
Fix will be included in OS v4.11
Confirmed fixed in 4.11. Thanks again KRIKzz
Title: Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
Post by: lee4 on February 11, 2021, 08:51 PM
Fix will be included in OS v4.11
I confirmed working on OS v4.11

can this fix be make available for X7 ?