EverDrive Forum

General => Mega EverDrive => Topic started by: IRL Random Hajile on November 20, 2020, 12:46 AM

Title: Ultimate Mortal Kombat 3 Trilogy crashes after Williams logo (Mega ED PRO)
Post by: IRL Random Hajile on November 20, 2020, 12:46 AM
Sup lads! Wanted to make this thread because I was talking to a friend through PMs in regards to ROM hacks, this one in particular (Ultimate Mortal Kombat 3 Trilogy) boots up fine. Sega logo and all that, but after showing the Williams logo and fading to black, it crashes...

It should be important to mention that this is the latest version v23 (5125) of the ROM hack I'm running, and also has the Bonus PCM music tracks applied which makes it a 13MB file. I should also mention that this exact ROM I'm using also worked perfectly fine on the Mega EverDrive X7 (when I was still using it at the time). Is there a supposed option that needs to be toggled for this hack to work properly on the Mega EverDrive Pro? Or is it some kind of firmware bug?
I'm using OS v4.07 btw.

EDIT: Upgrading to OS v4.08 still has the same issue as mentioned previously. Curious as to why on the older X7 flashcart this ROM hack worked, but not on the Pro.
Title: Re: Ultimate Mortal Kombat 3 Trilogy crashes after Williams logo (Mega ED PRO)
Post by: KRIKzz on November 21, 2020, 11:10 AM
Are you sure that you played exact same rom on x7? I tried on x7 13mb rom with bonus tracks and it fades to black after Williams logo just like on PRO. Roms over 10mb actually shouldn't work on real hardware, because area over 10mb occupied by the system registers. Such big roms can be played only if they be designed with using SSF mapper, but they don't.
Title: Re: Ultimate Mortal Kombat 3 Trilogy crashes after Williams logo (Mega ED PRO)
Post by: IRL Random Hajile on November 21, 2020, 12:52 PM
My apologies about the previous post of mine... legit kinda feel silly once I realized what was going on haha.
Upon further inspection, I may have unknowingly swapped certain ROMs around when I migrated files from the X7 over to the Pro whilst backing up data when I received my Pro weeks back.
I do vividly remember that when I played the hack on the X7, I got passed the Williams logo and I could hear the PCM tracks in the background and actually play through the hack, though it is quite possible that I may have used a slightly different build of the ROM hack which actually did work on the X7 with bonus PCM tracks.
If anyone else comes across this same issue with the William logo crashing, it's perhaps best to play the ROM hack without the PCM tracks patch applied.