Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mario64

Pages: [1] 2 3 ... 11
1
This remains an issue in 4.08

2
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

It fixable for sure but so far i have no ideas how to track it down, i tried but without success. May be it even not directly related to SVP core itself, for example while ago i fixed bug related to soft reset cmd which rarely used by games, only few known games uses it at startup. On MegaSG with Mega-pro those games just hangs, but worked fine with MegaSD. After all i found that MegaSG core has a bug which causes this problem: after soft reset cmd MegaSG begins fetching data from cart before than reset signal actually was released, but cart isn't response because reset still asserted by the console. At same time this behavior does not have any effect for MegaSD, likely because MegaSD does not return to menu after reset and reset signal not affect the cart whatever happens wit it. I was able to fix this problem on my side but this case explains why sometimes hard to have deals with clones, original systems also may have some bugs but they documented at least, but in case of clones usually no any info.

While I was writing this message, I got an idea that i should check if described above behavior isn't affect VR also. Hm...
Very interesting. Thanks again. I'm happy to help test or anything else you need to try and track it down.

3
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

4
Anyone besides lee4 able to play Free Run mode on MED Pro using Mega SG?

5
using Pro work fine for me
with X7 i confirmed broken
You're testing Free Run mode?
yes
tested free run mode

Mega SG i have boot direct to cartridge
Tried to send you a PM but it shows blocked

6
using Pro work fine for me
with X7 i confirmed
You're testing Free Run mode?

7
Confirmed this is an incompatibility between MED Pro and Mega SG for this game. Still needs to be fixed though as Mega SD does not have this issue. @KRIKzz?

8
Mega EverDrive / Re: Virtua Racing hangs on MED Pro
« on: October 30, 2020, 03:10 AM »
It's a Mega SG specific issue. It did the same thing on V2/X7.
Interesting. Wonder why it works on Mega SD though?

9
Mega EverDrive / Re: Virtua Racing hangs on MED Pro
« on: October 29, 2020, 11:43 PM »
which model system you are using ?
Mega SG on latest firmware. FWIW, the same rom works correctly on a Mega SD

10
Mega EverDrive / Re: Virtua Racing hangs on MED Pro
« on: October 29, 2020, 11:21 PM »
Virtua Racing (U) [!]
SHA1: FF969AE53120CC4E7CB1A8A7E47458F2EB8A2165
I'm using the exact same file and cannot play Free Run mode

11
Mega EverDrive / Re: Virtua Racing hangs on MED Pro
« on: October 29, 2020, 11:02 PM »
I have Mega Everdrive Pro Virtua Racing both modes work fine
but on Mega Everdrive X7 Virtua Racing the Free Run mode freezes
Not me. Which specific rom file are you using?

12
Just got my MED Pro and immediately ran into problems. Loaded up Virtua Racing. Selecting a regular game works but Free Run doesn't. If you choose Free Run it hangs. Have to cycle power to get back to the menu. KRIKzz could you please take a look?

13
EverDrive 64 / Re: Super Mario 64 3D All Stars (Rumble SUpport)
« on: October 07, 2020, 06:30 AM »
Well here they are: https://files.catbox.moe/ebgmal.7z

Apply to an unedited Shindou rom
Thank you!

14
Mega EverDrive / Re: Ys III MSU-MD audio tracks out of order
« on: August 28, 2020, 02:45 PM »
Any update @KRIKzz?

15
Mega EverDrive / Re: Ys III MSU-MD audio tracks out of order
« on: August 22, 2020, 10:16 PM »
It has been verified this is an issue specific to the MSU-MD patch.

Pages: [1] 2 3 ... 11