Author Topic: Repeatable issue wih SMS and GG roms on GG X7  (Read 2006 times)

0 Members and 1 Guest are viewing this topic.

Offline TyrionXavier

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Repeatable issue wih SMS and GG roms on GG X7
« on: June 29, 2020, 01:33 AM »
If I start a ny rom - GG or SMS  - then from that point forward, no SMS or GG game will load, even the same one.  The system presents me with a "Load/Save/Return to main" screen. 

For example, I loaded up Ultima 4 (SMS game) to test with, and it loaded and started playing just fine.  I saved my game and everything seemed well.

Later, I tried to load the game, and was presented with just a black screen, after a brief "Loading.." message.  This same behaviour exists for any SMS game I tried.  GG games would do the exact same thing - black screen.

I tried restarted the device, and this time I was presented with the "Load/Save/Return to Main" screen.  When this happens, and I can't get a reproducible series of steps to make it happen, the cartridge gets into an endless loop of "In Game Menu - Save State, Load State, Back to Menu".  If I select "Save State", it just brings ujp the menu.  If I pick "Load State", nothing happens, and if I select "Back to Main" I go back to the main menu to start the process all over again. 

If I go into the card files and delete everything from the SMSSYS folder except the SMSON.BIN file, then the process starts over.  The card initializes, I can select and load any game - once, and only once.

I have tried this in more than one Game Gear, and with more than 1 SD Card, seeing identical results.   I am using the latest Everdrive firmware that the site points to, however the site points to the SMS folder.  I don't see one specifically for the GG X7.

Is my cartridge just bad?

Offline BuckRight

  • Newbie
  • *
  • Posts: 28
  • Karma: +1/-0
    • View Profile
Re: Repeatable issue wih SMS and GG roms on GG X7
« Reply #1 on: November 29, 2020, 12:35 AM »
This sounds like an issue with the mSD card. Try running some diagnostics tools on it. Also try reformatting it and starting with clean files (not previously backed-up copies of the OS/ROMs). Try a 2nd mSD card as well.