Author Topic: Mega Everdrive Pro and Mega SG  (Read 755 times)

0 Members and 1 Guest are viewing this topic.

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Mega Everdrive Pro and Mega SG
« on: September 06, 2020, 06:08 PM »
I just got a Mega Everdrive Pro and it's working great on a Genesis 2 I have, however I have an Analogue Mega SG with the stock 4.7 firmware and the system fails to even load to menu. Is this FPGA clone system unsupported or do I need to have some setting changed within the menus?

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #1 on: September 06, 2020, 06:31 PM »
MEP works perfectly with my Mega Sg on the 4.7 firmware. The default menu hotkey on the Sg conflicts with the MEP’s, though, so you’ll want to change it in the settings (I went for left+start instead of the default down+start). If you use the 8BitDo controller this won’t affect being able to use the dedicated button on that.

Also, you’ll probably want to turn off the hardware Mega Key, as the Sg handles region locking automatically and the Mega Key prevents that from happening.

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #2 on: September 06, 2020, 06:37 PM »
MEP works perfectly with my Mega Sg on the 4.7 firmware. The default menu hotkey on the Sg conflicts with the MEP’s, though, so you’ll want to change it in the settings (I went for left+start instead of the default down+start). If you use the 8BitDo controller this won’t affect being able to use the dedicated button on that.

Also, you’ll probably want to turn off the hardware Mega Key, as the Sg handles region locking automatically and the Mega Key prevents that from happening.

I'll check the Mega Key settings on the Mega SG. I'm using this through the DAC with it doing the intro and then going to menu to start.

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #3 on: September 06, 2020, 06:44 PM »
Me too. But if it’s failing when you do ‘run cartridge’ you might have other issues. Hardware Mega-Key seems to prevent the Sg from automatically setting PAL mode, but of course with the DAC you need to use the switch anyway so the hotkey thing is more likely what’s causing your troubles since by default the Sg’s menu hotkey is the same as the MEP’s in game menu combo. On the MEP you can change that (unlike on earlier Mega EverDrives) but since the 8BitDo controller has a dedicated Sg menu button anyway it makes more sense to change the combo there, since it basically never gets used unless you’re on original controllers.

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #4 on: September 06, 2020, 07:12 PM »
Me too. But if it’s failing when you do ‘run cartridge’ you might have other issues. Hardware Mega-Key seems to prevent the Sg from automatically setting PAL mode, but of course with the DAC you need to use the switch anyway so the hotkey thing is more likely what’s causing your troubles since by default the Sg’s menu hotkey is the same as the MEP’s in game menu combo. On the MEP you can change that (unlike on earlier Mega EverDrives) but since the 8BitDo controller has a dedicated Sg menu button anyway it makes more sense to change the combo there, since it basically never gets used unless you’re on original controllers.

It's not booting to the main system menu with the Mega Everdrive Pro inserted at all.

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #5 on: September 06, 2020, 07:41 PM »
OK, then I’m not sure I can help with that!

Best I can suggest is to pull the cartridge and reinstall the 4.7 firmware, set the hotkey combo, leave the rest of the settings as default. Make sure you have the latest OS on your MEP as well. Then try powering up with the cartridge, launching it with the Run Cartridge method.

I seem to recall seeing a post somewhere about reset behaviour on the Mega Sg when booting direct to cartridge but couldn’t find it and may have imagined it. But my Sg and MEP (wish or without the DAC) work perfectly set up when booting to the Sg’s main menu.

Beyond that, might need to defer to Krikzz...

Good luck!

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #6 on: September 07, 2020, 04:58 AM »
OK, then I’m not sure I can help with that!

Best I can suggest is to pull the cartridge and reinstall the 4.7 firmware, set the hotkey combo, leave the rest of the settings as default. Make sure you have the latest OS on your MEP as well. Then try powering up with the cartridge, launching it with the Run Cartridge method.

I seem to recall seeing a post somewhere about reset behaviour on the Mega Sg when booting direct to cartridge but couldn’t find it and may have imagined it. But my Sg and MEP (wish or without the DAC) work perfectly set up when booting to the Sg’s main menu.

Beyond that, might need to defer to Krikzz...

Good luck!

Yeah I just tried it again. The Mega SG is on 4.7, the Mega Everdrive Pro is on 4.04, flashed the Mega SG changed the hotkey and it won't boot with the ED pro installed. Put in a retail cart and no issues, the ED Pro is working fine on a Genesis 2 I have, but due to outputs and options would prefer to use the Mega SG.

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #7 on: September 07, 2020, 06:30 AM »
Only other thing I can think of, and it's a long shot: are you using the actual Mega Sg power supply or something else? I suspect the MEP pulls more power than a regular cartridge, maybe it's drawing too much? Especially with the inline DAC.

I'm using a power bar with 4A of capacity in total across four USB ports, but the Mega Sg is all by itself there so it seems happy. But that's literally the only other thing I can suggest that might make sense.

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #8 on: September 07, 2020, 02:03 PM »
Only other thing I can think of, and it's a long shot: are you using the actual Mega Sg power supply or something else? I suspect the MEP pulls more power than a regular cartridge, maybe it's drawing too much? Especially with the inline DAC.

I'm using a power bar with 4A of capacity in total across four USB ports, but the Mega Sg is all by itself there so it seems happy. But that's literally the only other thing I can suggest that might make sense.

So the problem was solved, while I was using the official Mega SG power supply, I was using a longer USB cable to go to the DAC so that I could keep things better organized. Using the official Analogue USB cable, the Mega ED Pro does now work!

Thanks for the help!

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #9 on: September 07, 2020, 06:33 PM »
Aha, sneaky! I suspect the combo of Mega Sg, DAC *and* MEP (plus any wireless receivers) might be using very close to the maximum power capacity of the supply, and most cables likely assume connected devices will be more “normal” computer peripherals with little or no power draw. Glad it worked, that setup is just about as close to Sega perfection as you can get.

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #10 on: September 07, 2020, 06:35 PM »
(If you still need a longer cable though, I’ve had no issues with an Anker 10’ micro USB cable in the same setup.)

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #11 on: September 07, 2020, 06:37 PM »
(If you still need a longer cable though, I’ve had no issues with an Anker 10’ micro USB cable in the same setup.)

I may look into the anker cable, the longer one I was using just happened to be one I had from another device. I wasn't using a wireless pad either but do own one.

Offline DragonmasterDan

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile

Offline peterlanders

  • Newbie
  • *
  • Posts: 33
  • Karma: +3/-0
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #13 on: September 15, 2020, 11:25 PM »
I just have the plain white version, but I’m sure it’s the same inside. I’m using a fair number of them for different things. Good, reliable cables.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3358
  • Karma: +504/-2
    • View Profile
Re: Mega Everdrive Pro and Mega SG
« Reply #14 on: September 17, 2020, 04:36 PM »
Regular usb cable supports up to 500mA, higher ratings is not guaranteed. Mega-SG with Mega-ED for sure required more than 500mA, especially for running cd-core. I would use adapter and cable which can supply at least 1000mA