Author Topic: Mega Everdrive Pro + Mega SG Mega CD (US) won't work  (Read 318 times)

0 Members and 1 Guest are viewing this topic.

Offline fuenfzigmvier

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Mega Everdrive Pro + Mega SG Mega CD (US) won't work
« on: February 05, 2021, 07:45 PM »
Hey guys,

I'm at a total loss here and almost frustrated to tears. I just got my MED Pro the other day and immediately set it up. I'm using a Samsung Evo 32 Select on the Mega SG. I set it up as described in the manual, downloaded firmware 4.10, prepared the BIOS-files, formatted the SD card to exFat on my Mac, put some games on it and put it in the ED and then in the Mega SG. Everything seemed fine, Mega Drive games that I've tested worked, but Sega CD/Mega CD (US) I can't get to run.
I started Snatcher and it worked. Then I started Final Fight CD and it kicked me back to the Analogue boot logo. When I hit "run cartridge" again I got an error "disk I/O". When I reset the system not even Snatcher worked anymore. So I downgraded the Firmware to 4.08 and tried again. But I only got either black or pink screens when I tried to start a game. So I tried over 5 different BIOS files producing only the same results. Now and then It'd load the Sega CD start screen only to freeze out. So I went and tried all of my US BIOS files with firmwares 4.08, 4.09 and 4.10 again to no other outcome.
So I reformatted my SD card to FAT and tried all of the above again, still no game worked. Then I switched to a ScanDisk 32 Gig card and did all of the above again. Nothing. Please note, that both cards were working in Everdrives before (MED X3, ED GBA X5, FX Pak Pro).
So I went and got new BIOS files, new ROMs and formatted the Samsung card on a Windows machine properly. Then set up Firmware 4.10 and put all the fresh files on it. I now only have Redump/No-intro ROMs and BIOS files.
Mega Drive games work, Japanese and European Mega CD games work, but the #*%ยง US Sega CD games, which is 95% of my collection, still won't! But this time to a different effect: Now the card tells me that "I have to use .cue files if the file is part of a disc image". Well, guess what: I'm ONLY using .bin+.cue files! I've tried again with 5 US BIOS files and... nothing. Interestingly the only game that will work is NBA Hangtime. And I don't get the I/O error again.
So I downgraded again to 4.08 and tried only to see black- and pink screens again. Not even jp or eu games work on 4.08.
I really don't know what to do anymore. I think I have tried everything and anything and I would more than gladly use some help. Is my Everdrive broken?



« Last Edit: February 05, 2021, 07:52 PM by fuenfzigmvier »

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3383
  • Karma: +510/-2
    • View Profile
Re: Mega Everdrive Pro + Mega SG Mega CD (US) won't work
« Reply #1 on: February 08, 2021, 01:02 AM »
If japanese end European games work but only US doesn't then it must be related to bios files or to disk images. JAP/EUR games does not have any specific differences compared to US images. Also make sure that problem not related to console firmware version or console power supply. You need good usb cable and ac adapter which can supply at least 1A current

Offline fuenfzigmvier

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive Pro + Mega SG Mega CD (US) won't work
« Reply #2 on: February 09, 2021, 10:46 AM »
Hi Krikzz,

Thanks for helping me out. I managed to get it working, finally. I went back to the SanDisk card and formatted it to Fat32 on a Windows machine. I used the very first BIOS again and everything is working just fine now. It seems that a Mac does something different when formatting a Micro SD Card, which might cause this problem. So, in short, for other people that might run into the same problem, my setup is now:

> SanDisk Ultra Micro SD HC 32GB Fat32 (formatted on Windows 10), US CDX Bios 2.21