Author Topic: Virtua Racing Free Run mode hangs on MED Pro with Mega SG  (Read 1645 times)

0 Members and 1 Guest are viewing this topic.

Offline mario64

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #15 on: November 01, 2020, 04:25 AM »
Anyone besides lee4 able to play Free Run mode on MED Pro using Mega SG?

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3379
  • Karma: +510/-2
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #16 on: November 04, 2020, 05:31 PM »
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.

Offline mario64

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #17 on: November 04, 2020, 07:59 PM »
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3379
  • Karma: +510/-2
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #18 on: November 05, 2020, 01:15 PM »
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

It fixable for sure but so far i have no ideas how to track it down, i tried but without success. May be it even not directly related to SVP core itself, for example while ago i fixed bug related to soft reset cmd which rarely used by games, only few known games uses it at startup. On MegaSG with Mega-pro those games just hangs, but worked fine with MegaSD. After all i found that MegaSG core has a bug which causes this problem: after soft reset cmd MegaSG begins fetching data from cart before than reset signal actually was released, but cart isn't response because reset still asserted by the console. At same time this behavior does not have any effect for MegaSD, likely because MegaSD does not return to menu after reset and reset signal not affect the cart whatever happens wit it. I was able to fix this problem on my side but this case explains why sometimes hard to have deals with clones, original systems also may have some bugs but they documented at least, but in case of clones usually no any info.

While I was writing this message, I got an idea that i should check if described above behavior isn't affect VR also. Hm...

Offline mario64

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #19 on: November 05, 2020, 04:31 PM »
Free Run does not work with MegaSG using x7 or PRO, problem source unknown so far. But working fine on original systems. One of customers said that Free run works fine on MegaSG with older firmware.
Thanks KRIKzz. How can I help you track this down? I have MED Pro and Mega SG. Note that it does work fine on Mega SD so I think it is fixable via MED Pro firmware update

It fixable for sure but so far i have no ideas how to track it down, i tried but without success. May be it even not directly related to SVP core itself, for example while ago i fixed bug related to soft reset cmd which rarely used by games, only few known games uses it at startup. On MegaSG with Mega-pro those games just hangs, but worked fine with MegaSD. After all i found that MegaSG core has a bug which causes this problem: after soft reset cmd MegaSG begins fetching data from cart before than reset signal actually was released, but cart isn't response because reset still asserted by the console. At same time this behavior does not have any effect for MegaSD, likely because MegaSD does not return to menu after reset and reset signal not affect the cart whatever happens wit it. I was able to fix this problem on my side but this case explains why sometimes hard to have deals with clones, original systems also may have some bugs but they documented at least, but in case of clones usually no any info.

While I was writing this message, I got an idea that i should check if described above behavior isn't affect VR also. Hm...
Very interesting. Thanks again. I'm happy to help test or anything else you need to try and track it down.

Offline mario64

  • Full Member
  • ***
  • Posts: 155
  • Karma: +2/-0
    • View Profile
Re: Virtua Racing Free Run mode hangs on MED Pro with Mega SG
« Reply #20 on: November 20, 2020, 04:49 AM »
This remains an issue in 4.08