Author Topic: FXPAK Pro Scrambled Video Issue  (Read 751 times)

0 Members and 1 Guest are viewing this topic.

Offline Derf Jagged

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
FXPAK Pro Scrambled Video Issue
« on: December 21, 2020, 08:05 AM »
Hello! I just got a FXPAK Pro for my launch model NTSC SNES (1/1/1) and I seem to be having issue with it. The SNES plays other carts completely fine, and the FXPRO menu works fine, but randomly in games the video goes scrambled. On its stock firmware 1.10.2, it was happening about every 10 seconds in any game and then snapping back to normal, but on 1.10.3 its a little less often but still makes it unplayable. It also doesn't seem to always snap back to normal.

Video on my PVM CRT: https://youtu.be/9i70w7sOgXg

I think this is the same issue as these threads:
http://krikzz.com/forum/index.php?topic=9512.msg73754#msg73754
https://krikzz.com/forum/index.php?topic=9725.0

I might try the tape trick to cover pin 1 unless anyone has a better idea before then. I'm willing to do extensive troubleshooting, but this is my only SNES.

Edit: This was ordered from Everdrive.me so it shouldn't be old stock. Stock power supply. Firmware info screen at the start of the video (CIC pin lifted).
« Last Edit: December 21, 2020, 05:47 PM by Derf Jagged »

Offline Sid

  • Administrator
  • Newbie
  • *****
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: FXPAK Pro Scrambled Video Issue
« Reply #1 on: December 22, 2020, 09:54 PM »
Send PM
EverDrive support team

Offline Derf Jagged

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: FXPAK Pro Scrambled Video Issue
« Reply #2 on: December 23, 2020, 04:49 AM »
Putting paper over the pair of the leftmost pins worked as discussed here! Was there ever a permanent fix for this?

https://mobile.twitter.com/orzvektor/status/1238783001259118592

Offline nuu

  • Hero Member
  • *****
  • Posts: 1809
  • Karma: +81/-2
    • View Profile
Re: FXPAK Pro Scrambled Video Issue
« Reply #3 on: December 23, 2020, 06:05 PM »
I checked those threads and the problem appears to have something to do with earlier NTSC models (usually version 1/1/1, 2/1/1 or 2/1/2) not outputting the correct clock on cartridge pin 1 when FXPAK is used. Pin 1 is also used by SGB1 and Star Fox. I'm not sure how pin 32 is related as it's just WRAM select.

Unless it's just a faulty FXPAK, this must probably be fixed by ikari_01. He doesn't seem to be here so often anymore so you might want to try contacting him.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 854
  • Karma: +48/-0
    • View Profile
    • gamehacking.org
Re: FXPAK Pro Scrambled Video Issue
« Reply #4 on: December 24, 2020, 10:23 AM »
its flaw with snes ppu2
and took nintendo 3 fixes
example 2/1/3
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N & Pro M19 N1 | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
SNES jr | Super NT | Mega SG | Super Retro Advance | SGB v1 | 16bitPocket GBC | PCE+SSD3

Offline nuu

  • Hero Member
  • *****
  • Posts: 1809
  • Karma: +81/-2
    • View Profile
Re: FXPAK Pro Scrambled Video Issue
« Reply #5 on: December 24, 2020, 12:06 PM »
It looks like that since only the 2/1/3 version combination is fine, but are the PPU2 bug fixes known?
I only know about 4 version combinations: 1/1/1, 2/1/1, 2/1/2 and 2/1/3.

If it's only a PPU2 bug affecting those pins, Star Fox and SGB1 wouldn't work either on those systems, which I seriously doubt.