Author Topic: Turbo EVERDrive 2.4 NOT working on PCE?  (Read 280 times)

0 Members and 1 Guest are viewing this topic.

Offline SuttonBirdie

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Turbo EVERDrive 2.4 NOT working on PCE?
« on: January 22, 2021, 05:07 PM »
I recently purchased a Turbo Everdrive and it was version 2.4
Sometime is loads up and I can view the files and load up a game. But when the EVERDrive does load, the game will reset/crash itself after less than 1 minute. Pressing the reset button on the Everdrive does nothing. Manually turning off and on my PC Engine will sometimes load back the everdrive, but most times it wont. It is at this point that I will have to wait 30 minutes or so before putting in the Everdrive only for this scenario to happen all over again. I have tried this Everdrive with my original PC Engine and Core Grafx. I have made sure the switch was set to PCE and NOT Turbografx. I have tried different SD cards from different manufacturers and formatted them properly (then reinstalled the required files). I am not sure what could be causing my EverDrive to fail?
BOTH my PC Engine and Core Grafx load up regular HuCards instantly first time, everytime. So I can eliminate my PC Engines to not be faulty. ANYONE have any ideas?

Offline TheShadowRunner

  • Full Member
  • ***
  • Posts: 154
  • Karma: +9/-0
    • View Profile
Re: Turbo EVERDrive 2.4 NOT working on PCE?
« Reply #1 on: January 22, 2021, 11:50 PM »
TED requires more power than HuCards, could be a factor.

In what recap state is your current hardware ?