Author Topic: Msu1 video cracks up and sync problem on pal snes  (Read 15521 times)

0 Members and 1 Guest are viewing this topic.

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #15 on: April 16, 2015, 03:29 PM »
Test on 5 snes console, 3 pal snes(1 has 50/60hz switch) all 3 pal console are model no:SNSP-001(aus), Jap snes model HVC-002 , us snes model SNS-001
 Test with Akira demo, gangdam style music clip, zelda cd , super roadblaster, sorry that is all I have to test, very hard to find msu1 videos

Snes pal1 50/60hz switch- genuine power supply
Video cracks on all tests, roadblaster working
Zelda  60hz
https://www.dropbox.com/s/6pt9kvvnvvt0iw3/Snes%20pal1%2060hz%20zelda.mp4?dl=0Snes
Zelda  50hz
https://www.dropbox.com/s/xau1w9kjv36tv4y/Snes%20pal1%2050hz%20zelda.mp4?dl=0

 pal2 - genuine power supply
Gangdam cracks up pass half way, Akira working, zelda cracks up pass half way, roadblaster working
Akira
https://www.dropbox.com/s/or3j8eztspkcabz/Snes%20pal2%20Akira.mp4?dl=0

Snes pal3 - genuine power supply
Gangdam cracks up pass half way, Akira working, zelda cracks up abit into the intro, roadblaster working

Jap snes - genuine power supply with stepdown 100v
Gangdam working, Akira crack up later, zelda crack up pass halfway, I switched back to  1.7pr 3 everything works again, be sides small  glitch, firmware 1.6 has small glitch as well

Us snes - 3rd party power supply
Same as the Jap snes

Zelda https://www.dropbox.com/s/dsixaana3jlssno/Snes%20Us%20ntsc%20zelda.mp4?dl=0

Sorry video not so clear used my note 4
« Last Edit: April 16, 2015, 05:24 PM by teamvb »
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline ikari_01

  • Sr. Member
  • ****
  • Posts: 307
  • Karma: +80/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #16 on: April 16, 2015, 06:28 PM »
The minor glitches (wrong colors for a single frame, blocks) are due to SD card response time but shouldn't break anything.
The failure where the picture gets distorted and stays that way doesn't seem to be a missed MSU1 data read after all... these aren't single bytes missed but an entire block of data, either one DMA transfer from the SNES, one MSU data buffer size, or an SD card block (my guess is one of the former).
With the same card inserted, can you go to the sd2snes System Information screen and post a screenshot of it?
EDIT: Oh, forgot to mention that you need to wait for SD access time measurement to complete before taking the photo. ;)

EDIT2: Oh, just saw the Zelda videos from your 1st SNES in the list. It's the classical issue of some SNES consoles just not executing DMA transfers if DMA channels get initialized but never used. Apparently the ROM hack uses a fairly old version of my video player, I've taken some measures to fix that in the meantime... some more fixes are on the way, but of course the hack authors would need to update the players in their hacks.
« Last Edit: April 16, 2015, 06:49 PM by ikari_01 »

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #17 on: April 17, 2015, 12:08 AM »
SanDisk 64gb 1.7p3 my main card
https://www.dropbox.com/s/92b5lsmmqdbi4s7/1.7p3.jpg?dl=0
Panasonic 16gb 1.7p4 (test card)
https://www.dropbox.com/s/q4q8tfazbs09v6f/1.7p4.jpg.jpg?dl=0

Picture of sdcard, https://www.dropbox.com/s/jzga4l984yhx0bd/2015-04-17%2007.05.07.jpg?dl=0

I have a SanDisk class 10  64gb, 16gb,8gb and Panasonic class 4,
« Last Edit: April 17, 2015, 12:15 AM by teamvb »
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline saturnu

  • ヽ(^o^)丿
  • Hero Member
  • *****
  • Posts: 1168
  • Karma: +149/-0
    • View Profile
    • :D
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #18 on: April 17, 2015, 12:15 AM »

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #19 on: April 17, 2015, 02:51 AM »
I love to get one of those card, I am going to redo the test with a SanDisk class 10 16gb
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline ikari_01

  • Sr. Member
  • ****
  • Posts: 307
  • Karma: +80/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #20 on: April 17, 2015, 10:59 AM »
Access times look ok, a bit on the slow side which would explain the minor glitches you see.
I think it's the player code. I could reproduce it with a switch-modded PAL SNES. It happens less frequently but hopefully it will help me to track it down.

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #21 on: April 17, 2015, 01:50 PM »
Same problem with the SanDisk 16gbhttps://www.dropbox.com/s/v0q62x15o79h0hf/2015-04-17%2020.47.58.jpg?dl=0
Ikari I wish I can help, but I don't know how to, only I can  thing is testing, thinking about getting a faster sdcard https://www.dropbox.com/s/1jhth1cge50bege/NormalAppImage%286%29.png?dl=0

Would  a faster sdcard help
« Last Edit: April 17, 2015, 01:56 PM by teamvb »
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #22 on: April 30, 2015, 01:50 AM »
Sd2snes system
https://www.dropbox.com/s/15mm5cmrkpns76k/32gb_95mb.jpg?dl=0

I try a faster sdcard still no good, it was a SanDisk class 10 32gb 95mb/s
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline ikari_01

  • Sr. Member
  • ****
  • Posts: 307
  • Karma: +80/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #23 on: May 01, 2015, 02:18 AM »
That card is actually worse than the other two you posted. It may have faster streaming performance (which the sd2snes cannot make use of anyway) but has very high peaks in access time. This is crucial because the sd2snes needs the card to rapidly jump between two files when playing a video (MSU data file and PCM audio file).
Either way as I said your issue is most likely not caused by the SD card at all, I still believe it's caused by peculiar DMA behaviour of some SNESes. I tweaked my example video player a bit in the hope of fixing it.
Here's the updated ROM. Please copy this to any video demo that doesn't work for you (rename msu1vid.sfc to the file name of the video ROM and replace it) and see if it helps. This is only for the plain video player demos, not for the Zelda hack or the likes.

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #24 on: May 01, 2015, 03:03 PM »
https://www.dropbox.com/s/oyoge67af51kqkd/tweek%20player.jpg?dl=0
Test with the SanDisk 95mb/s pal snes with switch
System picture (I uploaded the wrong picture sorry) I run it 3 times, it is faster, I am very sorry for the wrong picture and wasting your time
https://www.dropbox.com/s/gfetpj4j2hxphro/san32gb95mb.jpg.jpg?dl=0

The update Not working, picture mess up, sound always  is ok
On 1.7p3 one of the demo bad Apple worked for fine on the pal with switch last night, today no,
« Last Edit: May 01, 2015, 03:06 PM by teamvb »
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #25 on: May 05, 2015, 12:21 PM »
The new Chrono Trigger Anime Intro MSU-1 works fine so  4 or 5 time on my pal snes with 50/60 switch
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #26 on: May 13, 2015, 05:53 AM »
i been encoding alot of videos for my sd2snes ,224x144 (tutorial from zeld)   using the tweaked player(thanks ikari_01)  most short video are ok but long one sound goes out of sync very bad  ,i encode a movie it played for around 18min and it loops back to the start,the player plays 2 files  sound  and video at the same time ,hard work for the sd2snes  ,i am using a SanDisk Extreme Pro SDHC UHS-I Card 32GB - 95MB/s and SanDisk Ultra SDXC Card 64GB - 40MB/s ,i think a faster card would help ,has anyone try it with a faster sdcard then my ,i know why watch video on a snes ,after getting stuck on a game ,i need to chill out snes with some nice video
« Last Edit: May 13, 2015, 06:16 AM by teamvb »
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline TheShadowRunner

  • Full Member
  • ***
  • Posts: 101
  • Karma: +7/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #27 on: May 14, 2015, 02:29 AM »
teamvb, you don't seem to get it.
For MSU-1 videos, card speed/class IS NOT THE DETERMINING FACTOR.
The important factor is the peak access time.

You can have class 10 UHS card at supersonic high speed, if they have high peak access time they will still suck for MSU-1!
Similarly, you can have class 2 cheapest card, if it's peak access time is low, it will perform perfectly.

The manufacturers don't indicate "peak access time" on their card's specifications.
Luckily Ikari has set up a page for that purpose where users can report their findings.
It can be seen here: https://sd2snes.de/blog/card-list

Hope it helps.

Offline teamvb

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #28 on: May 14, 2015, 03:48 AM »
thank you very much TheShadowRunner ,now i can start hunting for good sdcard ,one of sdcard reads
sd acc. time:0.302 / 0.537 ms avg/max , i am going to look for a faster(low peak access time) than this one i have,
EVERDRIVE 64v3,SUPERDRIVE v2, SD2SNES rev F ,UFO PRO SD,GAME DOCTOR 7 128MB USB,TURBO EVERDRIVE v1,MEGA EVERDRIVE V2,EVERDRIVE MD V1,MASTER EVERDRIVE,FLASHKIT MD,EVERDRIVE N8/FAMICOM

Offline TheShadowRunner

  • Full Member
  • ***
  • Posts: 101
  • Karma: +7/-0
    • View Profile
Re: Msu1 video cracks up and sync problem on pal snes
« Reply #29 on: May 14, 2015, 04:57 AM »
Ah, you have a card reporting 0.302 / 0.537 ms avg/max in SD2SNES.
Those are actually excellent values and MSU-1 videos should be perfect with it [on a pure NTSC system at least].

I don't think you can find better card than this (0.302 / 0.537 ms avg/max ).

The issue (stuttering, out of sync..) , as felt by Ikari, is most likely due to the PAL SNES.
In this case you have 2 solutions:
1. get a pure NTSC system from JPN or USA.
2. wait for Ikari to tweak the player (msu1vid.sfc) more for PAL systems, if it's possible.