Author Topic: Brand new Everdrive MD - almost no game works (only gets black screen)  (Read 4404 times)

0 Members and 1 Guest are viewing this topic.

Offline zoom

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Hi! I just got a brand new Everdrive MD from Retrogate.

99% of the games I try, don't work. It loads the ROM, then when the Sega logo should show up, nothing does. It's just black.

Some games work, I've been able to get something running, like Phantasy Star IV. Also Master System games seem to work well.

What is going on? I guess the cart is defective? I've tried two different SD cards.

It's a regular Mega Drive II console that works without fault.

Offline zoom

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
I discovered this well-guarded secret information:

.smd ROMS do not work?

Please make this information clearer, like by having it mentioned in the FAQ in the manual.

Offline Assman

  • Full Member
  • ***
  • Posts: 192
  • Karma: +17/-0
    • View Profile
SMD is a special format used by an old ROM copier, I believe, so yeah, I don't think they work. You need plain binary dumps (usually BIN, GEN or MD).

It probably should be mentioned somewhere, but honestly, as you kind of have to go out of your way to find rips in that format, it doesn't come up that much. Most stuff out there is BIN or GEN.

Offline filevans

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
No you don't have to go out of your way, if you have an old collection of roms like i do, collecting since the old days, all my roms nearly were smd format, and i was getting worried when nothing was loading, i was resorting to trying to download fixes at first until i realised it was the format, they seem to get detected as sms roms in a lot of cases at least

Offline QuidamPhoenix

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
I think it would be good info to add to the product page or manual in bold. I had the majority of my roms in .smd format and thought something was wrong with my Everdrive MD until I found this thread and started using .bin files.

Took me a couple hours of tinkering with different SD cards and formats etc until I figured it out. Some people might not get that far.

Offline segagamer

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
I am having the same problem even when I am using the correct format rom files.  In my case, the same file that worked previously did not work again later.  Sometimes, I could catch a glimpse of the SEGA logo for Genesis games before the screen went black on me.  Do I have a defective cart?

Offline J-E

  • Jr. Member
  • **
  • Posts: 88
  • Karma: +1/-0
    • View Profile
stupid question but do you use the firmware (something like MDOS.bin I don't remember) downloadable here in the website?