Author Topic: Power Supply died after playing some hours NTSC-Roms  (Read 2876 times)

0 Members and 1 Guest are viewing this topic.

Offline AW87

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +2/-0
    • View Profile
Power Supply died after playing some hours NTSC-Roms
« on: April 07, 2016, 09:26 PM »
Yesterday my original N64 power supply died after i played some hours NTSC-Roms on my PAL-N64. The konsole runs permanent in PAL64 mode for some hours before.

Can this have something to do that the power supply is defekt now? Has anybody made a similar experience or is this just fluke? I just wonder, because for years i had no problem with my N64 and now, when i have my Everdrive64 for some weeks, the power supply dies.

Can it be that the Everdrive needs more power than a normal cartridge? But the reason can also be, that this N64 was not used very often in last 4 years and now since i had the Everdrive, it was used every day for one or two hours. Maybe this was to much for the power supply?

Anybody an idea or similar experience?

By the way, i opened the defekt power unit and it has a smell inside like something burned. The copper coil was crumbled too. It was bad to open, i dont had a special tool for these kind of screws and then it was clotty as well. But in the end, i could open it. Looks not good inside. Seems like i must order another power unit from the internet and use this one here as a spare-parts-store, when the new one will have a problem too in the future.   :)

Offline keropi

  • Sr. Member
  • ****
  • Posts: 305
  • Karma: +17/-1
    • View Profile
Re: Power Supply died after playing some hours NTSC-Roms
« Reply #1 on: April 08, 2016, 12:14 AM »
That's the fate of old PSUs, they just die. It's irrelevant if you played NTSC roms or the ED64, for example an old (or crappy) pc psu can die while the pc is turned off and the psu operates in stand-by mode... get a replacement and cross your fingers the old psu did not damage the rest of the machine.

Offline AW87

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +2/-0
    • View Profile
Re: Power Supply died after playing some hours NTSC-Roms
« Reply #2 on: April 10, 2016, 03:12 AM »
I have my replacement-supply now, it`s a used Nintendo original. My N64 now works normally again. Luckily the console itself seems to get no damage, when the power-supply dies.

Okay, when the Everdrive-card or playing NTSC for longer time on a PAL console is not a bigger burden to the power-supply, then the reason why it dies is, that i use the N64 now very often since i have my Everdrive64 and before it was used only seldom over the last 5 years. Seems like this was to much for my power-unit. Now i hope, that the power-unit which i bought, will work for the next years, because it was also a used-one.

From Nintendo there are no new N64-power-units availabe and i didn`t knew about the quality of replacement-units like for example the ones from "Eaxus". Therefore i bought an used original one again. Anybody here that has any experiences with new Eaxus units? Are they okay from the quality-side or are they as bad as the Eaxus clone-controllers?