Author Topic: MegaKey Region does not save, every power off goes back to JAP NTSC  (Read 5464 times)

0 Members and 1 Guest are viewing this topic.

Offline keropi

  • Sr. Member
  • ****
  • Posts: 305
  • Karma: +17/-1
    • View Profile
I have noticed that the megakey region setting in my Mega-ED does not save. No matter where I set it, when I power off the megadrive and then back on it always reverts to JAP NTSC. Is this normal? Shouldn't it save the setting?
I noticed because I was getting japanese text in some games , but when I set it back to US NTSC I get english text - until I power down my megadrive.
Is this a bug?
thanks in advance  8)


edit: found a trick to get it unstuck from the same setting  :)

a. turn MegaKey State to OFF and reset , then power-off
b. change MegaKey Region to desired value, reset then power off
c. turn MegaKey State to ON (this time it kept the Region setting) and reset , then power-off

that got it unstuck and now it saves almost every time... I checked it several times and it seems to shift from regions and end up either in JAP NTSC or US NTSC that I have set with the trick above...  ???
« Last Edit: July 27, 2012, 11:37 PM by keropi »

Offline keropi

  • Sr. Member
  • ****
  • Posts: 305
  • Karma: +17/-1
    • View Profile
Krikkz any info on this? The region keeps changing at me, is it supposed to do that?  :o

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3383
  • Karma: +510/-2
    • View Profile
I can't reproduce it, for me megakey always stay in state which is was selected. By the way, megakey region re-setup each time when you choose new game, may be you just misunderstand about how is it work? Mapper and megakey options sets automatically when you change the game.

Offline keropi

  • Sr. Member
  • ****
  • Posts: 305
  • Karma: +17/-1
    • View Profile
oh I see... so it's not a static setting that depends on what game you select... I thought you set it manually and it was supposed to stay there  ::)
thanks for the clarification!  8)