Author Topic: Everdrive 64 v1.01 doesn't Boot (Black Screen)  (Read 5158 times)

0 Members and 1 Guest are viewing this topic.

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Everdrive 64 v1.01 doesn't Boot (Black Screen)
« on: January 21, 2018, 10:57 PM »
Hello, I've been using Everdrive products for years now, starting with the Everdrive MD back in 2010 :).

Anyway, I got one of the early Everdrive 64 units (v1.01, manufactured in early 2011) recently and it was set up for use with NTSC systems (CIC-6102), so I had to remove the existing CIC and replace it in order to use the cart with my PAL N64. I figured this was not a big deal, so I simply removed the CIC-6102 already installed in the cart and installed a CIC-7101 I got from a Killer Instinct Gold cart. De-soldering each CIC and soldering went very smooth, I had zero issues and everything appears clean and nicely done from what I can tell.

However, I'm not getting a picture from my N64. I've tried with and without an SD card but to no avail. On the front side, I noticed that there a couple of LEDs that light up for half a second, one of them is red and the other is green. Does this information help pin-point the issue in any way?

I know that both Everdrive MD and Super Everdrive hold a backup OS in case something goes wrong which you can access with a specific button combination, is there something similar on the ED64? Is there something else that goes over my head?

Many thanks in advance!

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1299
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #1 on: January 22, 2018, 03:08 AM »
Did you solder the chip the right way round?
WELCO
METOT
HENEX
TLEVEL

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #2 on: January 22, 2018, 10:31 AM »
Yes, I did.

Last night, I applied a little pressure to the right side cartridge and it finally booted up! Hopefully, putting in a shell will fix these issues, but the amount of pressure I had to apply has me worried that it won't. I'll let you know what happens.

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #3 on: January 22, 2018, 11:20 PM »
Well it turns out that putting it in the cartridge didn't help solve the issue. I've made a video showcasing the problem, I have to apply a lot of force on the right side of the cartridge in order for it to register.
What is interesting is that even after doing this, the cart doesn't seem to load any commercial games, be it either US or EU roms. I managed to load a few homebrew roms such as Wolfenstein 64 and a FlappyBird game, so I'm guessing it might just be the roms that are acting up.

I've uploaded a video with the whole procedure, as well as a couple of clear photos of the PCB. Hopefully someone can tell me if I did something wrong.

https://youtu.be/qXQL3OwZDJI

https://imgur.com/a/9ZVD9

Thanks in advance for any advice!

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1299
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #4 on: January 23, 2018, 04:57 AM »
Do you have a multimeter to test the connections between the CIC chip pins and the cartridge edge connector?
WELCO
METOT
HENEX
TLEVEL

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #5 on: January 23, 2018, 11:38 AM »
Sure, but what would that accomplish? Would it help diagnose why it's not booting games or why it's not booting in the first place unless I have it at an angle?

Anyway, I have another update, I was reading up last night on a lot of people that kept insisting that OS 1.29 was causing them issues. Well, I tried 1.28 and voila, every game I tried, be it US or EU, is booting just fine now.
Krikzz, you should consider including that older OS alongside 1.29.

In any case, any suggestions why that cart needs to be at an angle to work? I didn't really have many games for my N64, but Killer Instinct Gold and a Mario 64 cartridge I borrowed from a friend ran fine, in fact I beat Mario 64 on this unit this summer and I didn't have any contact issues. So, what could be causing the contact issue on my Everdrive?

Thankfully, I can try a friend's N64 hopefully within the week to see if I have the same issues there.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3378
  • Karma: +508/-2
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #6 on: January 23, 2018, 02:18 PM »
In any case, any suggestions why that cart needs to be at an angle to work? I didn't really have many games for my N64, but Killer Instinct Gold and a Mario 64 cartridge I borrowed from a friend ran fine, in fact I beat Mario 64 on this unit this summer and I didn't have any contact issues. So, what could be causing the contact issue on my Everdrive?

It must be some soldeing defects, may be some pins on fpga has cold soldering points

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #7 on: January 23, 2018, 03:27 PM »
What do you propose I do? Is there an easy way I can check this out?

Also, would you be willing to repair it for me if I send it to you and how much would that cost?

Thanks in advance for your suggestions!

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #8 on: January 24, 2018, 02:47 AM »
So, I had the chance to meet up with a friend and borrow his N64 and a few games to test on my system. The games all read fine and I had no issues playing them for a few minutes. I then swapped my system for his N64 and tried the Everdrive 64 on it with and without a shell. The results were identical to my system unfortunately, so I'm lead to believe there is something wrong with this cart. :(

Could it be something I did while soldering the replacement CIC? I'm fairly certain I did a very clean job as you can see from the photos and I have cleaned all contacts as much as possible. What can I do to fix this?

Offline saturnu

  • ヽ(^o^)丿
  • Hero Member
  • *****
  • Posts: 1182
  • Karma: +156/-0
    • View Profile
    • :D
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #9 on: January 24, 2018, 01:48 PM »
With solderwig and enough flux, you can resolder the fpga without hot air.
A flat tip on the iron would be ideal.
There are a lot tutorials on yt on how to do this.

I would practice a bit on old broken hardware before fixing the ed64, just to go sure.

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #10 on: January 24, 2018, 05:00 PM »
Do you have any of those tutorials handy? I don't really understand what exactly I should be searching for and I'm afraid that I don't have the proper tools to do this in the first place.

Offline saturnu

  • ヽ(^o^)丿
  • Hero Member
  • *****
  • Posts: 1182
  • Karma: +156/-0
    • View Profile
    • :D
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #11 on: January 25, 2018, 08:16 PM »
sure, here is a tutorial about soldring smd parts just with a soldering iron
https://www.youtube.com/watch?v=b9FC9fAlfQE

if this scares you too much, maybe you can send it to krikzz or ask someone who already has the required experiance or even better a hot air station.
i would guess that a lot of these cell phone repair shops can do this for you in just a minute, if you leave a tip.

Offline f2bnp

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #12 on: January 25, 2018, 09:38 PM »
Thank you very much for all the help!

I hope this is where the issues lie, hopefully it'll be an easy fix and I'll get to play all my favorite N64 games again :). I'll be back in a few days with info on whether or not it worked.

Offline noz1380

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #13 on: February 18, 2018, 10:26 AM »
Could I ask you share the link to 1.28? I'm having issues with 1.29 on my v1.01 board too.

Also I have a very old arcade board that suffers similar to your pcb. You have to twist the board to get the correct colour. I'm sure it's a dry solder joint, but I have a few more ICs to check....

Anyway good luck, and if you can share 1.28 that would be awesome.
Thank you.

Offline D4v3WTF

  • Sr. Member
  • ****
  • Posts: 279
  • Karma: +9/-0
    • View Profile
Re: Everdrive 64 v1.01 doesn't Boot (Black Screen)
« Reply #14 on: February 18, 2018, 05:41 PM »
Could I ask you share the link to 1.28? I'm having issues with 1.29 on my v1.01 board too.

Also I have a very old arcade board that suffers similar to your pcb. You have to twist the board to get the correct colour. I'm sure it's a dry solder joint, but I have a few more ICs to check....

Anyway good luck, and if you can share 1.28 that would be awesome.
Thank you.

Hi, here you can find the OS v1.28. http://www.nightfallcrew.com/28/07/2012/everdrive-n64-os-update-v1-28-released/
N64 PAL Games Collection: 204/243
N64 PAL Demo Collection: 1/1
N64 Region Free NTSC Games: 1
Everdrive 64 v2.01 modded UltraCIC II
SD2SNES Rev. F modded Rev. H