Author Topic: Strange flicker or artifacts with N8 on RetroUSB  (Read 4635 times)

0 Members and 1 Guest are viewing this topic.

Offline Spartan

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Strange flicker or artifacts with N8 on RetroUSB
« on: June 18, 2018, 08:02 AM »
Hello all.
I recently purchased an EverDrive N8 (japanese cart) from Stoneage gamer.  Great experience but I have a question I'm hoping someone can help me out with...

I play NES games on a RetroUSB AVS system.  When playing original NES carts, everything is fine.
However, when plugging in the EverDrive N8 I see a bit of flicker or artifacts in quite a few games.  I'm not even sure if flicker or artifacts is the correct term...so I've included a link to what I'm trying to describe.

You can see in the top image, every second or so the image will flicker here inside the area that I've outlined in red.  The bottom image is what the image looks like normally.  It isn't much of an issue while playing a game as you're moving and this doesn't happen on every screen in every game but I've seen it often enough.

https://imgur.com/PQvYty0
https://imgur.com/uBQIxD3





Both my RetroUSB and N8 are running the latest software.  Is this a known issue? Is there anyway to mitigate this at all?

Thanks for any feedback/help

Offline James-F

  • Sr. Member
  • ****
  • Posts: 340
  • Karma: +29/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #1 on: June 18, 2018, 08:07 AM »
This may be related:
https://forums.nesdev.com/viewtopic.php?t=10104

I have these 'line glitches' on the original hardware too with super mario.
Mega Everdrive x5, Everdrive 64 v3, Everdrive N8, N8 Pro, SD2SNES, Joyzz.

Offline Spartan

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #2 on: June 18, 2018, 08:36 AM »
Thanks for the reply.
Do you primarily see it w/ Super Mario because I see it with Super Mario and quite a few other games on the EverDrive N8?
For example I just fired up Metal Gear on the EverDrive and I see similar graphical glitches.  However when I plug in an original cart of Metal Gear, I don't see graphical glitches.
This all while playing on a RetroUSB AVS.

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #3 on: June 18, 2018, 03:33 PM »
This is a known issue, but it was fixed in the beta firmware.

Offline Spartan

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #4 on: June 18, 2018, 04:26 PM »
Thank you for the info.  Good to know that this is a known issue and not unique to me.
When you say beta firmware, are you referring to the AVS?  If so, you know which revision of beta firmware addresses this issue?

Thanks again

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #5 on: June 18, 2018, 08:30 PM »
I'm referring to the Everdrive N8 beta firmware available here. Both revisions correct the issue, but beta 2 is recommended over the first one.

Offline Spartan

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #6 on: June 19, 2018, 04:21 AM »
Thank you so much for pointing this out to me!
Just installed the beta 2 firmware and it resolved the issue.
Fantastic, what a painless fix!  Thanks again!

Offline sqwirral

  • Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #7 on: July 13, 2018, 05:50 PM »
Argh, I'm getting those flickering lines in Zelda 2 on AV Famicom, got my hopes up for that beta firmware but it didn't fix them.

Offline Eunos

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #8 on: October 29, 2018, 11:09 PM »
If you are referring to the horizontal lines that will occasionally flicker across an entire scanline in Zelda 2, that happens in the original cart as well.

Offline sqwirral

  • Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #9 on: December 25, 2018, 11:43 PM »
If you are referring to the horizontal lines that will occasionally flicker across an entire scanline in Zelda 2, that happens in the original cart as well.
Really? Interesting! It doesn't seem to happen with my Disk System version (but does happen when running the FDS version on everdrive). I was going to buy a NES cart just to test this out but the game + a nes-to-fc adapter isn't that cheap.

Offline toadhall

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #10 on: January 08, 2019, 11:20 AM »
Huh, weird. I have that flickering line problem on an original SMB with my AV Famicom. Just got my N8 today so will test it soon.

Offline leonquest

  • Sr. Member
  • ****
  • Posts: 455
  • Karma: +22/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #11 on: March 11, 2019, 09:44 PM »
I'm referring to the Everdrive N8 beta firmware available here. Both revisions correct the issue, but beta 2 is recommended over the first one.

So that's it then? the beta 2 is the definite firmware for the N8 on the AVS while we wait for Krikzz to start working on it again? I never really tested my N8 since the updates started rolling out in hopes they would be fixed by the time I did get around to play NES, so I have RC6 installed on the AVS's latest, but as per your advice I will move to beta2 if that works best.
Everdrive64 V3 - SD2Snes rev. f - Everdrive N8 fami - MegaEd X3 - PS IO - MODE - MISTer

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: Strange flicker or artifacts with N8 on RetroUSB
« Reply #12 on: March 13, 2019, 08:01 AM »
Please check the date. You have replied to an outdated post from back when beta 2 was still current. I have recommended RC4-6 since then, 4 seems to be the most stable of these. Beta 2 is not recommended.
« Last Edit: March 13, 2019, 08:14 AM by brianvgplayer »