Author Topic: New Master Everdrive X7 problem  (Read 7327 times)

0 Members and 1 Guest are viewing this topic.

Offline theretroprojects

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #15 on: April 21, 2020, 12:37 PM »
So after more testing I have concluded the issue isn't the power supply, I had 19v and 3amp feeding in and still it failed, thanks for the feedback fille1976, so I packed the system away and accepted (for now) that's just how its gonna be. My work around was to power the system on with the everdrive in, on error screen for a few minutes, then quickly power off and on, and it would start working. The reset trick didn't really help, think it must have just been chance when I tried that.

Until yesterday, when I decided there had to be a fix for this, I was thinking this had to be a capacitance issue (it starts working after a short time of power being applied). Looking around I stumbled on this post https://krikzz.com/forum/index.php?topic=6192.0  ??? (thanks Neto)

Investigated the POR for my PAL VA3 board and found this https://www.smspower.org/forums/post73474?highlight=#73474 (thanks MaxWar)

So, I replaced my C1 with a 0.47uf (thats all i had) and I had 50% more success, it even booted in 60hz mode for the first time, previously it never booted in 60hz mode, only 50hz.

I will be ordering some 0.1uf caps asap to test, but wanted to share this asap, maybe you're in a position to test yours now with a 0.1uf.

Some interesting things (for me at least) I'd like to share and may be of use.
Cleaner RGB output https://www.youtube.com/watch?v=jR7jAQ2e9TQ
Alphabetize your files on the everdrive http://www.anerty.net/software/file/DriveSort/?lang=en


Good Luck everyone struggling with this.




Offline relo999

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #16 on: May 04, 2020, 01:02 AM »
Got the same issue, have a roughly 70% change of getting "bad memory" and 30% for "software error".

Also tried replacing C1 with a .47uf but got the same results as with the stock 1uf cap. Haven't tried the .1uf cap.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3356
  • Karma: +503/-2
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #17 on: May 19, 2020, 02:57 PM »

edit:
Found information about checksum calculation bug in some sms bios version, not sure if it source of problem, but looks like possible option. Working over solution... Likely it cannot be fixed without sending cart back for exchange

Hi again KRIKzz, I thought it was only my case,  but I am still very interested in playing it with my MS1. I have a question for you KRIKzz, Could I send the cart back to you for a exchange?, as I tell you I am still very interested and it is impossible to play with my European MS1.

Thank you.

Plase use "contact us form" at krikzz.com for exchange request.
I bought European master system1 for tests, but unfortunately it had bios version which is worked fine. So i made a fix according to collected information about checksum but didn't actually tested this. Very likely it should work fine now.


Offline freaktmp

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #18 on: May 19, 2020, 04:58 PM »
If you're looking for beta testers for the fixed firmware I volunteer!  :D

Offline relo999

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #19 on: May 19, 2020, 05:32 PM »

edit:
Found information about checksum calculation bug in some sms bios version, not sure if it source of problem, but looks like possible option. Working over solution... Likely it cannot be fixed without sending cart back for exchange

Hi again KRIKzz, I thought it was only my case,  but I am still very interested in playing it with my MS1. I have a question for you KRIKzz, Could I send the cart back to you for a exchange?, as I tell you I am still very interested and it is impossible to play with my European MS1.

Thank you.

Plase use "contact us form" at krikzz.com for exchange request.
I bought European master system1 for tests, but unfortunately it had bios version which is worked fine. So i made a fix according to collected information about checksum but didn't actually tested this. Very likely it should work fine now.

Mine's already on it's way to you. If the current solution doesn't fix it it might be handy to know how to recognize Master systems with the problem bios. So for the record, mine has Alex Kidd in Miracle world installed and serial number 41A 01332, hope that can help.

Offline Otaku_Punk

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #20 on: June 18, 2020, 04:14 PM »
I'm seeing the same issue as aranya and Xofdam with my new Master Everdrive x7 that arrived this morning. Thought I'd add my info incase the larger sample size helps shed some light on the issue.

I'm using an unmodified PAL Mark 1 Master System, which has Hang-On and Safari Hunt built in.

I've just gotten in touch with the supplier for some advice. Is this something that can be fixed with a software update, happy to hold on if so?

Offline herbevore

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #21 on: June 23, 2020, 12:27 PM »
I also am having the same issue with my Master Everdrive x7 with my modded Master System model 1, displaying the message "software error"  and it has v3.4 in the top right of screen.

The model info for my console is:
Power Base PAL-B(VV)
Model No : 3005-03-B
Rating  : DC 9V 850mA
Serial No : 40G 60312

It just arrived in Australia after many months in the post and I was looking forward to giving it a red hot go. Sigh...

Offline Otaku_Punk

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #22 on: July 03, 2020, 12:09 PM »
Just checking in on this before my return window closes. Is the general advice to people with this issue to return the hardware to their supplier or hold out for a software update?

Offline relo999

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #23 on: July 03, 2020, 02:33 PM »
Just checking in on this before my return window closes. Is the general advice to people with this issue to return the hardware to their supplier or hold out for a software update?
Think you need to send it to Krikzz or send it back to the seller. I needed to send it to Krikzz to get it fixed, and it's on it's way back to me now.

Offline Otaku_Punk

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #24 on: August 03, 2020, 01:50 PM »
[Think you need to send it to Krikzz or send it back to the seller. I needed to send it to Krikzz to get it fixed, and it's on it's way back to me now.
How did you get on with your cart relo999?

Offline relo999

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #25 on: August 04, 2020, 05:47 PM »
[Think you need to send it to Krikzz or send it back to the seller. I needed to send it to Krikzz to get it fixed, and it's on it's way back to me now.
How did you get on with your cart relo999?

Still haven't got it back, toke a month at customs in the Ukraine it seemed and now has been almost a month since it has been shipped back to me after it being fixed. So I haven't been able to see if it's actually been fixed.

Offline nikeymikey

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #26 on: September 06, 2020, 03:56 PM »

edit:
Found information about checksum calculation bug in some sms bios version, not sure if it source of problem, but looks like possible option. Working over solution... Likely it cannot be fixed without sending cart back for exchange

Hi again KRIKzz, I thought it was only my case,  but I am still very interested in playing it with my MS1. I have a question for you KRIKzz, Could I send the cart back to you for a exchange?, as I tell you I am still very interested and it is impossible to play with my European MS1.

Thank you.

Plase use "contact us form" at krikzz.com for exchange request.
I bought European master system1 for tests, but unfortunately it had bios version which is worked fine. So i made a fix according to collected information about checksum but didn't actually tested this. Very likely it should work fine now.

Hi krikzz, Do you know what bios version you have on your PAL SMS1? I have just bought a MSED X7. I own an SMS2 but have a SMS1 on order which i have region mods ect planned for. Id rather use the mk1 due to the RGB output.

Offline nikeymikey

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: New Master Everdrive X7 problem
« Reply #27 on: September 07, 2020, 05:18 PM »
I have just confirmed that my X7 does not work with my Master System 1 :(
 I believe my bios is v2.4 as that is what appears on the screen with the words software error, it has Hang on and Safari Hunt built in.  Don't know if that helps you diagnose the issue at all. I was wondering if somehow we could replace the bios with a different version if that would work?

Otherwise do i need to return this to my supplier or can i return direct to you for the update?
« Last Edit: September 07, 2020, 05:20 PM by nikeymikey »