Author Topic: Turbo Everdrive v2.5 not booting on Turbo Express  (Read 631 times)

0 Members and 1 Guest are viewing this topic.

Offline JessieR

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Turbo Everdrive v2.5 not booting on Turbo Express
« on: May 17, 2020, 06:52 AM »
I just got a Turbo Everdrive v2.5 from Amazon, and I'm not able to get it to boot on my Turbo Express.

I have a 32gb microSD, formatted FAT32. In the root directory I have a folder called "TBED" with the file "os.pce" inside it, just like the disk setup image shows. But when I turn it on, I just get a blank screen.

I tested the system with a Ninja Spirit HuCard, and it worked fine. I use the same microSD for my Everdrive GB X7 and it works fine there. It seems like it's just the Everdrive itself that's not working, unless there's something I missed?
« Last Edit: May 17, 2020, 08:15 PM by JessieR »

Offline Link83

  • Full Member
  • ***
  • Posts: 108
  • Karma: +7/-0
    • View Profile
Re: Turbo Everdrive v2.5 not booting on Turbo Express
« Reply #1 on: May 17, 2020, 09:23 PM »
Is the PC-Engine / TurboGrafx-16 region switch in the correct position on your Turbo EverDrive?

Offline JessieR

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Turbo Everdrive v2.5 not booting on Turbo Express
« Reply #2 on: May 18, 2020, 08:03 AM »
That was indeed the problem! The unit I got has the cover over the circuit board that makes it hard to access or even see this switch, which is probably why I overlooked it. Thanks!

Still not in the clear entirely, now I'm getting an error code but at least that I can look up and troubleshoot. Hard to read on the Express screen but I think it says F4, which seems to be related to trying to use the same card for multiple drives. I'll have to dig up a spare card to try it with.